Python Scope not loading in UIPath studio

i tried stepping down to the lower version for UIPath python and my activity disappeared. Previously i used v1.6.0 and the only lower version is v1.4.1. v 1.6.0 worked fine for me previously so i dont think that is the issue.

@anonymoususer ,

Can you check your system performance while running the python script? for proper execution the memory should be below 80% and CPU usage below70%

yes, the system performance is okay

Hello, @anonymoususer Welcome to the Uipath community.
Kindly Update the python package to the latest version and try it.

(post deleted by author)

I ran into the same problem after updating studio and project(from Windows Legacy to Windows) yesterday. I try to install python3.10 or update python3.9 but it still stuck here

I found similiar problem , python scope with python activity 1.6.0 will make Ui Path.Executor not responding, any idea to solve this problem

Python 3.10
Python Activity 1.6.0

have you solved, i’ve same issue and i don’t know how to solve…

Hi guys, my problem is still the same. But i managed to work around it by moving certain executions to python itself, so to exclude any python activity from UiPath for now. More coding work but at least thats the only way out for me

1 Like

I have got the same problem. and no soution on the web. Its very annoying

1 Like

Hi guys, did you manage to solve the problem mentioned above? I have the same problem, but the solutions described above do not help me. Yhank you!

Ran into the same issue on a “Windows” project with the Python Scope. The process just hangs there with no error message. I created a “Windows - Legacy” project and used the exact same settings and code and my script ran without issues.

Python v3.10
UiPath.Python.Activities v1.6.0
UiPath v2022.10.3

Hi @anonymoususer, were you able to fix this issue? I have been facing a similar issue for a couple of weeks now and there seems to be no resolution. The one which uses Windows Legacy cannot be worked upon now as it will be phased out soon.

Hey @loginerror, would you be able to help here?

Can someone please help me with the below issue:
After upgrading the UiPath Studio community version to 2022.10.3, Python Scope didn’t execute also it doesn’t throw any error.
Can anyone help me to solve the issue?
Thank you in advance

Hello all, having the exact same issue where the it hangs on python scope, no error message or anything, just gets stuck there forever. I tried using version 1.6 and version 1.4.1 to no avail. Please provide a working Solution.

Hi @Klozkoth

Would you mind sharing a sample Legacy project that will also cause an issue when converted to a Windows project? Does this also happen for you with simply dummy scripts, or is there something specific in the script itself that is triggering this issue?

I am also facing the same issue. For me the script is working fine in windows legacy projects, not working in latest windows projects.

Hi, did you managed to find a fix for this?

Just to loop the knowledge together. For anyone with this issue, could you please try out this solution and report back if it fixed it for you?