Python scope / How to run python scope

How to run python scope

I followed it after watching YouTube, but it doesn’t work.
What’s the problem?crying

hi @sooyeon_Lim

Please ensure that you have python installed.
You should give a proper path of python environment folder.
Target should be selected correctly
and version should be selected which is installed in your system.

Once you have this, the script runs fine.


I’m really sorry, but can you tell me as an example? I’ve watched several videos and copied them, but I really don’t know. I don’t know if I can’t. Please help me.

Hi @sooyeon_Lim

This is the example workflow that I ran, (13.1 KB)

I have python3.9 installed in my machine.

Thus this Ran successfully.

1 Like

Thank you very much. You’re an angel.
Can I make it based on what you made and ask for help again if it doesn’t work?! I’ll be back after researching it! Thank you.

Sure @sooyeon_Lim

Mark this as Solution if that worked.
Later you can raise another post if need be.

Happy Automation! :slight_smile:

I’m so sorry, engine reset error? The message appears. Could you take a look at my file? For me, this.Only the py file is executed (the command to rename the folder automatically), and UiPath does not have to display any message windows. (75.9 KB)

There are some things that you put wrong.
Also Invoke Python Method would call a function which is created inside your Py file.
And I cannot see any function created with OS name in your file.

Possibly can you try with Python 3.9
There might be some incompatibility with .NET Runtime version.

1 Like

Please refer above images for all activities to be used to execute a Py script.
Note: squarenumber(under invoke python method) is the name of func/method in script

1 Like


Please check this detailed guide and validate


1 Like

I love you so much! It’s changed perfectly.
I newly installed and set Python to 3.9 and it changed! Thanks a lot.

Thank you. It was helpful!

Thank you. It was helpful!~~~~

1 Like


There’s another problem. A message appears stating that one or more errors have occurred. What’s wrong with this?!

I’m sorry. Is the file you created made so that I can’t paste anything other than python activity? I was going to paste the activities I made, but I couldn’t

I think the developer created Windows Legacy? I’m a Windows file, is that why it doesn’t run?

Yes, you can mimic the workflow in Windows, but cannot copy component from one to another.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.