Publish Packages to orchestrators with Azure DevOps

Really Appreciate your time atleast i am happy to see reponse :slight_smile:
Btw i have given the OrchURL, Userid&pwd but still i am getting issue. Tried many source still issue is not resolved.
Regarding the technical user would you pls elaborate or provide some steps so i can try and update you.
I also read that new verison is coming up i am glad. So does it mean that current version has any limitation with connecting azure devops with UIPath?
Once again thanks for your response.

I suggest we have a look at it at a quick zoom chat. For this, pls get in touch via mail

Thanks Thomas Stocker for you help, I am able to complete the devops with uipath.

Dou you upload also libraries or is the feature request still not popular enough?

2 Likes

Hello,

I tried to build the DevOps build and deployment process mentioned above and ran into problems. I needed to install and configure the DevOps Pipeline Agent on on-premise(self-hosted) computer. Azure Pipelines Agents - Azure Pipelines | Microsoft Learn

The second problem was that there is a new v2 plugin (UiPathPack@2) appeared on the VisualStudio market. I successfully built the pipeline mentioned above, but I needed to read this topic: UiPath Integration - Visual Studio Marketplace

And I built pipelines to Community Orchestrator using the token authentication described in this topic.

I hope this helps you!

Hi , I am new to UI Path, could you please let me know how to identify or form the Orchestrator Path? Thanks

Hi, just read this thread: UiPath Integration - Visual Studio Marketplace
At the end of this: “How to set connection arguments for Automation Cloud Orchestrator”

There is a picture which explains everything. You should create authentication token on Orchestrator first. Then connect DevOps Release pipeline using this token.

Hello Stephu
We have just released a new version of the UiPath Azure Devops Plugin.

Whats new:

  • Support for deploying libraries
  • bug fixes
  • Introduced a new step to download CLI (optional)

Best regards
Thomas

3 Likes

Hello Thomas. Works perfect. Thanks.

I will update the my tutorial.

Next time it would be nice if uipath take fast effort. We developed this function in our own module because uipath was very slow to develop these features. :wink:

Has anyone had success deploying to a locally hosted Orchestrator? I’m getting an error in the UiPath Pack task, but I have a feeling it’s a firewall issue.

Yes, my orchestrator is locally hosted. It works fine with Azure DevOps.

Yes, we have an on-premise orchestrator too, but since friday i get timeout error for the uipaht pack task: ##[error]Unhandled: connect ETIMEDOUT 137.116.207.86:443

Can I ask what version of Orchestrator you’re using? We are using 2019.10.16. However the documentation from marketplace only says you need version 20.4 for the Test task, and I’m trying to use the Deploy task, so that shouldn’t be the issue.

I was also having issues with the pack task as well, but after I removed the orchestrator connection parameter it finally worked. It’s optional anyway.I still can’t get Deploy task to work though.

Please check my post in other topic: UiPath Azure Devops Integration - #11 by schwarzp

Here i’m describing the solution uipath support gave me. Since then UiPath Pack and Deploy tasks are working again for me.

I’m running into the situation where newly added arguments to the main WF in Studio, that were not already declared in the project.json at the time of the push to DevOps are not included in the package build task. Manually modifying the JSON or publishing direct to Orchestrator (which rebuilds the project.json) from Studio prior to the push to DevOps appears to fix this issue. Are others experiencing this or am I doing something incorrectly?

Hello Stephu, is there any update regarding the next step of including the Workflow Analyzer to pipeline ?

Thanks in advance for your support

Hi, I followed all the steps but my UiPath Deploy task fails with this error:

Error deploying package: Error: The process ‘C:\hostedtoolcache\windows\uipcli\1.0.7573-25446\x64\uipcli.exe’ failed with exit code 1

and when I check the log, the error message is System.Net.WebException: The remote name could not be resolved: orchestratorurl

Has anyone got this error message?

Thanks!

1 Like

@fxd25, thanks for asking… I was also facing similar issue when using the Azure plugin

So, I tried the steps slightly different way using command lines of UiPath Cli…

I have documented the steps in below article …hope that helps…

1 Like

Hello,
We are using on-premise Orchestrator 2019.10.18 with DevOps. It works.