Publish of workflow project to Orchestrator failed. You are not authorized!

Hi All,

I was trying to publish package through studio to orchestrator.
i have followed below steps:-
1.Connection between studio and orchestrator
2.tring to publish package

But getting error as “Error: System.ApplicationException: Publish of workflow project to Orchestrator failed. You are not authorized! —> System.ServiceModel.FaultException`1[System.ServiceModel.ExceptionDetail]: You are not authorized!”

Please help.

Can you please check the status of the Robot in the tray?

If possible, provide the screenshots of it

@SagarSB - can please check connection status in robot try Or just so a check for check the orchestrator settings.

Hi,
Could you tell us what item(s) of the orchestrator settings should be checked.
I am facing same problem too since Upgrade Orchestator version to 2018.4.4 .
Best Regards

Cpnnection status is Connected, licensed.
@sandipauti @HareeshMR

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

Can you post a screenshot of the robots list in Orchestrator?

Check if the robot has the original “Robot” role assigned to it (or any role that has permission to create packages).
For more about roles, please check https://orchestrator.uipath.com/docs/about-roles

@Mateus_Cruz
still getting same error.

I have assigned robot role but not working.

Is there any difference between User roles and Robot roles.

If yes then how to set roles to Robot.

Setting check marks of Edit/Create roles of Processes at Update Robot Role Page(Users>Roles>Robot) of Orchestrator according to Your Advice,
I Succeeded to publish my robot to Orchestrator.
Many Thanks