Publish Of Library Project To Orchestrator Failed - Package Cannot Be Published To The Shared Feed

How to proceed when publish of library project to Orchestrator failed and package cannot be published to the shared feed?

Troubleshooting Steps: The below procedure can be performed and verified

  1. Check if the Robot/ Studio is connected to the Orchestrator and make sure the Robot is assigned to any environment in the Orchestrator
  2. Create a new sample library and check if the same error is received
  3. Check if permissions for libraries in Orchestrator are provided. Navigate to tenant -> Manage Access -> Roles
  4. Check the role assigned to the Robot user and modify accordingly in the above path
1.png

5. Navigate to Tenant -> Settings -> Deployment and change the following settings
2.png
  1. And the Robot is assigned to the correct folder, and Studio is trying to publish to the right folder
  2. If the issue still persists, create a new ticket with UiPath Technical Support for further assistance.
2 Likes

Hi, unfortunately the Screenshots from Position 3 and 4 are not available. Could someone update the Post, that i can fix the failed upload of a library.

Hello Raiko, Thank you for using our Support Knowledge Base.

Kindly use the below link to access the mentioned KB.

Thanks!

https://uipath-survey.secure.force.com/CaseView/articles/Knowledge/Publish-of-Library-project-to-Orchestrator-failed-Package-cannot-be-published-to-the-shared-feed

Hi Saritha,

thanks for your Feedback. Unfortunately with this KB URL the Images are as well not exist. I have also change the Network, with the same Result.

image

Hello Raiko,

Please try now.

https://uipath-survey.secure.force.com/CaseView/articles/Knowledge/Publish-of-Library-project-to-Orchestrator-failed-Package-cannot-be-published-to-the-shared-feed

Thanks!

1 Like

Thanks a lot, now the Images are available.

It took me FOREVER to find the page that had these settings. Perhaps in the future posts like these could provide a breadcrumb trail on how to get to it.

Thanks.

1 Like

I have no idea where these screens are located in the app, it’s not very helpful.

@carlor, can you point me to the location where I can find these settings?
…I’ve also trouble finding it… :frowning:
Kind regards,
Daniel

Steps to resolve this issue :slightly_smiling_face:

  • Go to orchestrator then tenant .

  • Go to setting , scroll little bit you will find libraries as a heading.

  • There will be lots of options like feeds , deployment and security .

  • you need to check only host tenant feeds .

  • save it , it will work and then publish it.