Protected excel sheet left unprotected after appending

Hello everyone,

We have a process that reads and appends new rows to an excel sheet using the activity Append Range (to workbook). The excel sheet is protected apart from these exceptions: You can edit cells in two of the columns, you can add new rows.
However, after the robot has added new rows to the sheet, the sheet is left unprotected.

Does anyone have a suggestion as to why, or perhaps a fix for this?

Thanks.

I Just tried to replicate this issue using Append Range activity.
It is working fine. Protected workbook remains protected even after appending.
Which activities are you using?
Kindly provide screenshots or upload the project for debugging.

Thank you for your reply.
I was perhaps i bit unclear. It is the sheet that is protected in excel.

  1. I first read an excel sheet using: UiPath.Excel.Activities.ReadRange

  2. I make a few changes to this resulting DataTable.

  3. I then append to the sheet using: UiPath.Excel.Activities.AppendRange

When finished, the sheet is still said to be protected, but the columns that could previously not be edited can now be edited and deleted. So it is as if the “protected” setting have changed, and I am now allowed to select and edit locked cells.

Hi,
I just tried the same and it is working fine for me.

Please check the excel sheet protection properties and also try manually doing the same and check if it is getting removed

Turns out the sheet is still locked for other people. Seems I am allowed to edit the rows that I have added using RPA, but they are still locked for other users.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.