Proprietary .NET App Not Consistently Working from Orchestrator


#1

I have an unusual problem, and I am wondering if anyone has had a similar experience.

One of the first processes we got to production updates an internal app running .NET 2.0 framework - the app takes asset delivery dates as input from users and subsequently updates several tables and triggers some batch processes. Previous to our purchase of Orchestrator, I would log into console using vSphere client, start the robot, disconnect, and everything worked fine. If the proprietary app threw an error message for any of the assets, the process captures the error text and outputs all into a CSV at the end.

However, since we have scheduled with Orchestrator, I have a problem not with the robot but with the app itself. The robot executes process successfully, but half or more of the input records are logged as errors with no error text and no sign that our app even tried to add the delivery date. If I immediate log into console and run after, everything works as before.

Logically, the very first thing that I tried was to set the runtime to Log Into Console = Yes, but the outcome was still the same. I also tried defining the resolution in the runtime, but that has not helped either. It’s made more frustrating by the fact that the input rows that produce this textless error are not necessarily sequential, so I can’t point to a specific time in the process where it stops working.

Has anyone had a similar experience where an internal web application wouldn’t work consistently in the Orchestrator environment? FYI, we’re set up for high density on Windows Server 2016.