Project Migration error with Uipath

Hi all,

I am new to UiPath, presently working with Screen Scrapping I have spyed the field on one system and everything is working fine when I move the same xaml to other system the process is not able to spy the fields and giving the errors as shown below

What are the parameters that should be made constant to make the xaml work on all bots

Any suggestion will be helpful

Thanks in advance

hey Harsha,

remove all static selectors,
if not resolved, hen please share me your selector, I will suggest

regards
Aditya

Hi Aditya,

I cant upload the .xaml due to the security issues, i will provide u with the screen shots of the process.

1.The below mentioned image is the complete process that I have created.

  1. In this image I am showing the default Selector value

  2. This is the edited selector image

  3. After moving the process to other system the process looks like this

  4. The error that I am getting when I have moved to process to other system is shown below
    error1

Thanks in advance

I notice that, the url you are passing that is not a web page

you have saved that oage locally on old system, which is not available in another system
“C:\users\….jpg”
this file is not accessible from new system
that’s why this issue is coming

Hi,

For your ref I have sent that file but while working i have changed the path

my Question is, whether the page is on Internet or you have downloaded into local Machine!!

A/c to this error, the specified path is incorrect:
image

fix it, it will work fine

Regards
Aditya

Hey Aditya,

  1. The page is on the local machine, I have changed the path dynamically on the system on which the process is running.

  2. The file exists on the specified path when tried to open the same with the local instances works fine but when tried to open the xaml from other system facing I am facing the above mentioned issue.

Hey Aditya can you just do me favor\help, can u just provide a screen scrapping example which reads data from a image, the image will opened in a browser and showing in a message box and that which works fine on all systems.

Any suggestion will be helpful and thankful.

Thanks and regards
K harsha vardhan

Hey @harsha8687,

there is no issue with this workflow as I think because it is working in one system!
only the problem it may be is the proper path is not correct!!

once you should do one thing, try to print all dynamically generated paths (as you mentioned in above post) is that path is correct?
try this approach

as far as idea is concerned you can go through this threads:



regards
Aditya

ok sure @aditya.prakash Thank u