Project is download from the TFS but is open as read only

I am using a TFS to save the project files. When downloading the project it is displayed as read only.

The files are downloaded in the local folder but when it is open, the studio displayed a message as read-only. No error messages are displayed, it is happen with all the projects.

In the logs I only find this reference:

09:57:51.0142 => [ERROR] [UiPath.Studio.Launcher.exe] [13] Object reference not set to an instance of an object.
09:57:51.9644 => [ERROR] [UiPath.Studio.Launcher.exe] [13] Object reference not set to an instance of an object.

Any help?

@irving.alveo

Welcome to our UiPath community.

Right click on that file name β†’ Properties β†’ uncheck Read Only option.

Hi, Thanks for your reply! It is not related to windows security options for the file. I checked it with another computer and read only checkbox is correct.

Make sure your project is checked out.

Hi Alexandru,

The check out options is not available after downloading the project. none of those options are displayed.

thanks for your help.

Could you try deleting the folder and trying to grab it again from TFS?

Hi @irving.alveo,

So there are couple of things we need check when you get this error.

  1. Check if the code / repo was correctly updated with a valid change set. This will ensure that the user who committed the code has write access to the repo. All the while the studio is connected to the tfs repo.

  2. If you manually have downloaded the repo from azure devops tfs repo, you must do it from the user who has read write access. If your user does not have write access and you download the repo to the local folder, the contents will be read only( extacly like you are expierincing)

Try doing this.

Instead of downloading the repo manually from azure devops, connect to the repo via the studio. Studio will anyway download a local copy of the repo and the user used to connect azure devops to studio.

Best practice with tfs repos.

  1. Try to avoid downloading repos from GUI of azure devops
  2. Always remember to use the finish editing option when you are trying to commit the code
  3. Ensure all your users have the correct roles and access for each tfs repo / azure devops project
  4. Once you connect the tfs repo to UiPath studio, use the option @alexandru mentioned
  5. If in doubt always use the Get Latest Version option. If your local code is the newer version the repo version (remote) will not overwrite the local version

Finally, according to my troubleshooting , the error you are experiencing is related to the user access and roles in the tfs repo.

1 Like

Hi Maciej,

Yes, I tried that option too. I also change the local folder repository with the same results.

Thanks for your comments.

Have you given a try to the suggestions posted above?

I suppose the first step would be to try and verify the TFS works as it should with Studio by:

  1. Creating a new project
  2. Checking it in to TFS
  3. Closing it
  4. Opening it from Studio (from the Open Recent list, for example)

It should properly detect that the project was connected to TFS and open it in editing mode.

After this simple test, we will know whether this is an issue with Studio itself or just with the particular TFS project.

Don’t download the project. Use the clone function from Studio.

Most likely if you just download it you will end up with a read-only folder. This is how TFS works, not a UiPath Studio-specific issue.