Processes triggered via Orchestrator into remote server takes too long to start

Hi all,

I’m triggering a process via UiPath Orchestrator into my remote server. It takes about 2 minutes until the package pass the “Installing package” mark, though this doesn’t happen when the process is triggered on my local machine.

When the process is triggered via UiRobot on the Windows toolbar, it takes the same amount of time.

Did anyone ever had a problem like this? I don’t know if the package is supposed to be installed every single time it runs on my server.

Hi, did you ever find a solution to this?

Hi @bradsterling

Please see this post (and the topic that it links):

Thanks for the comment! The UiPath Support team helped me solve the issue! Our firewalls were configured correctly, however, the below modifications fixed the issue. I’ll post for others in hopes it can help in the future.

  1. Navigate to following path: C:\Windows\SysWOW64\config\systemprofile\AppData\Roaming\NuGet\NuGet.Config and do the below changes
    Comment
    <!-- <add key="nuget.org" value="https://api.nuget.org/v3/index.json" protocolVersion="3" /> -->
    and add
    <add key="local" value=".\Packages" />
    Note: You need administrative access to make this change.
  2. Please add below attribute in the following files UiPath.Service.Host.exe.config,UiPath.Executor.exe.config,UiRobot.exe.config,UiPath.Agent.exe.config [These files can be found in Robot installed location- C:/Program Files X86/ UiPath]
    <configuration>
    <runtime>
    < generatePublisherEvidence enabled="false"/>
    </runtime>
    </configuration>
  3. Navigate to following path C:\Program Files (x86)\UiPath\Studio\NuGet.Config and comment the below lines
    <!-- <add key="Official" value="https://www.myget.org/F/workflow/" /> -->
    <!-- <add key="Community" value="https://gallery.uipath.com/api/v2" /> -->
  4. Restart the UiPath robot service after making above changes
2 Likes