Process works in attended mode but not in unattended

Hi guys,

I’m doing a process migration from an old environment to a new environment. In the old environment, the process runs well in both attended and unattended modes. But in the new environment, it runs only in the attended mode but fails in the unattended.

The bot fails to identify certain UI elements in the new environment with unattended mode and it fails. The selectors and all are fine. I have tried changing simulate, and send windows messages properties and it didn’t work at all. Also gave delays nothing worked.

Finally, I tried with ‘UiPath.UIAutomationNext.Activities.Nclick’ package activities and it also didn’t work.

Can it be any other issue related to the bot settings or anything?

Can you suggest to me any solution for this?

Thank you.

Hi @minolp,

Can you please see below post solved by me.

I think your setup is incorrect Please install your bot in service mode.

Hey mate,

I installed it in the service mode as you suggested and the process started to run in the orchestrator without the pending status but the process fails in unattended mode. The bot is unable to identify some UI elements.

Can you please share the Error message? So that we will get the idea.

HI @minolp

Can you share the screenshot of this?

GOto → task manager-> Details-> Search for uipath and you can see multiple Uipath.ServiceHost like that share that one


try to create seperate folder for new process and in manage tenant add unattended for your process