Process that stopped working, suddenly started to work with 0 ingerention

Dear Community!

As a Junior RPA developer at my company on recent friday afternoon i run into very strage issue (at least from my point of view). As currently im the only RPA developer in company as our senior dev found out new career opportunieties I can rely only on my knwoledge and power of internet.

So to move onto the main topic, on friday 2 complety unreleted porcesses stopped working throwing same exact error. I process i just simply re-written to newer acivities as it was run on legacy verios and i fixed a few bugs that were in the original. That helped.

But to my shock the second process that was written by our senior dev maybe like 3 or 4 months ago, that i didnt even touch for this 4 days, on Tuesday mornig around 9:00 started working fine again.

Error i was getting in both processes:
Info: Code: generalException
Message: An error occurred sending the request.

Microsoft.Graph.ServiceException: Code: generalException
Message: An error occurred sending the request.
—> Microsoft.Identity.Client.MsalUiRequiredException: AADSTS50126: Error validating credentials due to invalid username or password.

To add more contex credentials used in this 2 are used in other multiple processes and they run with no issue all the time.

I change / reseted password for user multpile times, asked admins to check if user is not block etc etc.

If you wuoul like any additional details plz let me know.

Help! :slight_smile:


Generally it is adviced to use retry scope around the grpah api activities…retry with a small deay might fix this issue…

Mostly the the bots would have failed at same time due to latency or so…so for safelty include them
Inretry scope with a small delay


Well the problem is, that there already is retry scope + both proceses are run like every 10 min each day, so basically for past 4 days none of this was succesfull and now, out of the blue 1 process started working again without any change.


From where the credentials are fetched?

Is there been a change in creds or was there a maintenance window?


  1. No maintenance window.
  2. Credencials are stored in orchestrator fetched by get credentials activity.
  3. And for sure they are correct.


Is the bot running on same machine as well? Or different machien?

Ideally with this setup you should not face issue with wrong creds


same machine, thats why it is strange to me and i run out of ideas what could possibly generate such issue