Process stops working through orchestrator

orchestrator
activities

#1

I have 2 processeses on my robot which I schedule through the orchestrator. One of the processes works perfectly fine while the other don´t. I get the message " time-out exceded and activity could not be performed correctly"

The robot is installed on a vdi and works perfectly fine when manually started when I’m logged in to windows server but when started through orchestrator it doesn’t work. And I cannot even take a screenshot as it gets failed every time, so I can’t see the problem.

  • screenshot is copied from the reframe template and when logged in it works fine.
    -I have set screen resolution through orch runtime tab.
    -I have tried “invoke workflow”.
    -I have tried "RemoteDesktop_SuppressWhenMinimized "
  • According to my logings, the computer logs in and the web browser starts but then no element could be found.
  • One process works fine on the same environment, same license same settings.

#2

Hi! I guess it can be a resolution problem @Ahed

The bad thing is that you can’t get an screenshot to see which is the used resolution but… I would recommend you to use “Launch interactive Workflow” activitie, in which you can specify exactly the resolution that will use the robot in the VM.

Take a look at this screenshot:

Launch your process inside this activity and put the exact resolution that you want. If its still failing you will know that it isn’t resolution problem.

Try this in the VM and please tell me the results @Ahed

Best regards :mage:
Pablo


#3

Thanks for the reply, I have tried that as well and i have set the screen settings through orch


#4

is it still failing? So we can guess that is not resolution issue


#5

The problemt ois that the VM cannot interact with the screen at all…