Process Stage issue in reframework (running in Orchestrator)


I Created one project for website automation using google chrome…

  1. Initapplication – login website works
  2. Process state – get data using select item option to select the locations
    3.end state – logout the website…


First point is working fine…
move next stage only message box popus


doesn’t run other functions on the below message box…

Directly goes to end state…

why this is running like this ?

help me…



Hi @Shyam_Pragash ,

Could you provide us with more details of the Process Part ?

Is the Message Box Inside the Process Block ? And After the Message Box UiPath won’t be executing any other functions?

May we also ask you to Put a Breakpoint at Get Transaction Data Block, and Debug the Workflow. So in this way we would be able to Identify the flow of the Process Step by Step.

Hi @supermanPunch

Code is working in debug mode, run file mode while running in the studio… no issue…

after publish code into orchestrator. Tigger to run the process that time i am getting this issue.


You may want to check what get transaction does?
maybe bot goes into get transaction state and no records are found so it ends the process.
check few points

  1. Check your get transaction stage and post how the transition moves based on the condition.
    you could debug the workflow by putting a breakpoint after init stage and execute each step.
    still not solved then please share screenshots or workflow for more understanding


i have get transaction one by one to run in debug…

Code in Process State.

issue in Orchestrator running.


while u run it via orchestrator, are u able to see the message box?
Can u replace msg box with logs and try to run from the orchestrator?

HI @Krutika_Kotkar

log message and message box are present.

Can u send the file ?


is official works can’t be share…

take remote my system.