Process runs without errors from studio, but fails with selector error from Orchestrator

The process goes into a virtual machine and opens cpr application in citrix environment to search for patient tickets. The process runs without errors, when run from studio, but it fails when started from [Orchestrator] .

The [robot] type is unattended, the machine key is correct, and the robot is connected and licensed (enterprise version).

Before failing, several cv click selectors are passed and return no errors, but when it reaches this cv click it cannot find it:

Tried changing resolution on robot but of no use. Again, after starting job in orchestrator if the virtual machine is opened then it is running fine without errors. But when it is scheduled, and virtual machine is not opened cv click fails.

Please need some help. Thanks


Welcome to the community

Is the robot installed in service mode?

And while changing resolution did you set login to console as false?


Hi Anil, thanks for the reply. How do I check if it is in service mode or user mode?

Hi @keerthan

Try this expression in assign

Process.GetProcesses.Any(Function(p) p.ProcessName="UiPath.Service.Host")

If this returns true I beleive it would be service mode

Ideally during installation you would select that is available only for service mode


yes, it is in service mode, and while changing resolution console was false.


Generally when the selected image is very small this might happen…can you try increasing the size of thw image if its small …and to restrict try giving a region to aearch if possible

And what exactly is the error that you are getting?


Hello @keerthan

I hope the robot is installed in the VM and you are opening the application in the same VM. If yes, then why CV click is used in the process instead of normal click activity?


Hi @Rahul_Unnikrishnan,
I’m automating citrix application in vm, so i’m using cv click

Please check the below doc.


Thank you @Rahul_Unnikrishnan, but I have already tried those settings, but still there are issues. First 3 cv clicks it is working, later it stops working, I have re indicated it and published again, but with no success

Hey, @keerthan
Same thing is happening few clicks are working for me, But Remaining are not working.Even the Element exists as well.

Have you found the Solution for your Problem?