Process run on a remote machine by Orchestrator cannot run unattendedly

Hello Everyone,

I have a process that logs in a user through a website. I am using TypeInto and Click activities for the actions in the web. It runs smoothly but when I publish it to Orchestrator, it will fail on those actions. The orchestrator unattended robot is installed on a separate machine. No problem triggering it but when it opens the browser and I’m not logged in to that machine, all it can do is open the browser and wont be able to type and click on the username and password fields. I found out that it can only pass the run if I logged in on that machine and make sure I will not minimize the rdp and will not move the mouse.

My goal is to have this process run into that remote machine on a scheduled basis (mostly, after work hours) but it won’t allow me to. Are there any other activities that are independent of the user and does not interact with the mouse like webdriver do? I noticed the click activity does grab your mouse during debug and will always force maximize the active window. Please help.

I have tried some stuff like setting requiresUserInteraction to false on the project json file but it goes back to true automatically after I publish it (probably because of the nature of typeInto and click?) so if there are alternative activities that I can use please let me know.


Hello @Mark_Mac,

I remember that few things should be done to work properly.

  1. Set the screen resolution on the robot settings
  2. Set the properties to the activities that are working in the background.
    (simulate type is working in background and also is the fastest option, if is supported in your scenario)

It might help.


Thank you so much @wasea! Setting the SimulateType in the activities property to True has worked for me and I have confirmed it to run on all conditions without logging in to the machine. Have a wonderful day!


That’s great.

Happy automation!


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.