Process off when exit from VM

Hi Everone, I running the project on VM every day and it is working well when I am using the VM, But after scheduled to run in the morning without access to VM it gives an error, which means the process does not work when the exit from VM (off).
I did some searching and I found the same issue solved by running the studio in service mode, is there now another way to solve the problem? or if I change it to service mode will it affect the existing projects in VM?

Hi @RPA_Dev13

Please check IF there is any UI Interactions and also please check the below thread

Regards

Thanks, I will test and let u know the result

Just to let you know it is the same problem, the process does not work when the VM is OFF./

Is there any other solution for this issue???

Hi @RPA_Dev13

Does your process have any UI Automation? Is the automation on Desktop Application?

Regards

Yes should get the data from the queue and insert it into the browser application

@RPA_Dev13

First for unattended bots to work…service mode robot installation is needed…so first install robot in service mode

Existing processes will not be effected because of this change

Also generally it is adviced to signout the vm rather than just disconnecting…not logoff but only signout

Service mode and signout should solve your issue ideally…

Cheers

Hello everyone,

Apologies for the delay. Unfortunately, even after installing the studio in service mode, I am still encountering the same issue where the process loses elements when logging out from the VM. I appreciate any additional suggestions or insights.

Thank you for your patience

Hi @RPA_Dev13

In user robot setting Set login to console like this


Also in unattended steup tab- Give only the domain\username (If you give full mail address it will not work) For correct username you can type whoami in cmd copy the ouput here.

Hope this will work :slight_smile:

1 Like

Thank you for your message. I have tried the suggested steps, and they seem to be working for one project but not for the other. Could it be that the project created over two years ago is being affected by the lack of upgrades in activities and packages?

Awesome :100:. Highly likely but you can try to upgrade packages. Also check if it is installed in service mode or not where it is not working.

1 Like

Hi Guys ,

I would like to thank everyone who helped me with this issue. The latest update is that the projects are now working well, following these steps:

  1. I uninstalled all Studio versions from all machines and reinstalled them with the latest version in service mode.
  2. For your information, for those with enterprise licenses, I believe the Studio will install automatically in service mode.
  3. I also adjusted the robot settings as shown in the photo below, following your suggestions."

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.