Process freeze but works(takes long time to run)

Hello
I get strange behavior when I run processes. At regular intervals when the process is started it seems like something is timed out, I don’t get anything wrong but it only takes a very long time to process something … This makes the process “freeze” for maybe 1-2 minutes but continues after that and works fine for a while, then “freeze” it again etc). First thought that it depends on Excel (in which the process fetches and writes data) “hangs”. But what I can see this happens even when Excel is not read (can be a click somewhere in the process)
Does anyone have the same problem? Is this a known bug? How do I find out what interferes with the process and create this delay / freeze?

Hi,

You can add step by step or for process milestones a log into a text file. So that you can identify where it get delays…

Hi
welcome to uipath community

do you mean like this freezes ONLY at the point where excel file is read
if so are we trying to read data from multiple sheets or are we using any loop followed by after reading or are we using any DELAY activity before or after excel application scope activity

Cheers @Haltob01

Hello
I have several processes with the same phenomenon, so I guess there must be a general flaw in my processes.
took out the log file when I run a process, you see in the log that it is 2-minute “breaks” at regular intervals, and it seems to be when variable “Tom” is filled with new data in this particular process (have marked these with "- - ") …Could that variable be incorrectly coded? It is a date variable taken from excel as a row.2019-10-15_Studiologg.zip (5.3 KB)

Hi All,

It is not an Excel problem. I have exactly same problem as it was described by Haltob01 .

I am running XBrowser application, that is completely different than any MSFT applications.

It is probably Studio problem: We have two totally different applications which have exactly same problem using Studio.

Regards

Hi,

We have the same kind of problem with processes freezing.
It waits for hours without doing anything and as soon as we connect manually with RDP, the process goes on and finish successfully.
Do you have this kind of problem ?

Regards

Hi! Also I am having freezing problems … I haven’t wait to long to see what happens … but all these freezing problem I just figure out that was in my case that I have a loop in my process that got freeze …

Also in your processes you guys are using loops? just trying to identify what is the problem here …

I also have the same issue. I have narrowed it down to the Start Process activity for me. I have to start Word a few hundred times with a template Word document, then save it as a PDF, then close out Word, then loop back and Start Process by opening Word again. It will run perfectly for maybe 10 loops, then randomly (no commonality on the data) it will freeze for exactly 60 seconds, then proceed like nothing was wrong.

I have put Write lines before and after the Start Process activity and this is definitely where it is hanging. Seeing that it is 60 seconds each time makes me sure it is some internal time-out parameter waiting on something, but no errors are generated and everything looks fine when running.

Has anyone been able to figure this out? My start process is hanging for exactly 2 minutes each time I run the process. Never times out and always continues the process after the 2 minute pause.