Process finished due to no transaction data

Hi everyone my process in ending by showing there is no transaction data.
I’m downloading attachment from gmail and saving that in a folder
After i need to process that attachment in SAP
In the INIT transaction i used downloading attachment xaml file
And in Process transaction i used Process of file in SAP Xaml file
But in get transaction i don’t have anything to use from orchestrator

If i run the process I’m getting process is ended due to there is transaction data
Can anyone help me to solve this

Hi @ranaprathap928

What condition u put in get transactionstate?

@NIVED_NAMBIAR I’m not using any condition there I’m just passing 1 argument of attachment location

Can u share a screenshot of get transactionstate
@ranaprathap928

@NIVED_NAMBIAR

Hi @ranaprathap928 - You will need to set the TransactionItem variable as something so that the process will continue to the Process state, as per the below image of the state transition.

As you are not using queue items from Orchestrator, you must also change the variable type, for example to be an integer.

You could alternatively change the condition in the state transition to see if “tempdemo” has been set to a value.

Hope this helps!

@ranaprathap928

You should assign value to out_ Transaction variable

Also put condition such that if ur transaction is over , transactionitem should assigned to nothing that after the automation will be ended

Hope it helps

Mark it as solution if it is correct

Nived N

sure @NIVED_NAMBIAR i will try

sure @katharine.hardy i wil try this

@katharine.hardy i tried it but Capture1 still i’m getting same error

@katharine.hardy , @NIVED_NAMBIAR if possible can you share me any Xaml file for get transaction item without using orchestrator.

Hi @ranaprathap928

U can use this

Here from excel sheet I am assigning transactionitem

But u can get idea of putting condition of assigning transactionitem

You can check here in this link

Hope it helps
Nived N

thanks @NIVED_NAMBIAR i will check

1 Like

Please reply if u got it @ranaprathap928

sure

1 Like

Still I’m getting same @NIVED_NAMBIAR

Hi @ranaprathap928

I think get transaction data workflow is missing ?

Hi @NIVED_NAMBIAR i did this based on your workflow
Even if the get transaction workflow is there also its showing same error

What condition u put to assign transactionitem

I’m calling downloaded attachment location from config file