Process execution error - Licence error: You need to be registered at Source


I’ve been using community version of Studio for a while and it suddenly stopped working when i was executing processes with the below error message:

System error: Licence error: You need to be registered at Source: UiPath.UiAutomation.Activities

I’ve since got a enterprise license, successfully activated it and linked my machine to a licensed enterprise orchestrator. My robot shows as connected so i don’t see an issue there.

However when i run processes in studio i still keep getting this same error message.

Any advice?

I’m having this exact same problem. The processes won’t run even when the machine is disconnected from the orchestrator. The machine has an enterprise license.

Hi @esa.andsten,

I got a resolution after i went to UiPath directly. As with many error messages i have experienced; the resolution seems somewhat/totally unrelated to the message you get.

Below is the response i got:

Issue Description:
“System error: Licence error: You need to be registered at Source: UiPath.UiAutomation.Activities”

This issue usually occurs on Studio v2018.3.2 and above, when executing projects that are using the 18.3.6864.20582 version of the UiPath.UIAutomation.Activities package.
If you have projects created with Studio v2018.3.1 which were using the UiPath.UIAutomation.Activities dependency version 18.3.6864.20582 you must open them in Studio and the UiPath.UIAutomation.Activities dependency must be updated to the 18.3.6877.28298 version.

Please note : If you ever installed other 2018.3 versions than the Enterprise Studio v2018.3.1 edition (eg. Community Stable v2018.3.0 or any prior beta versions for both Enterprise and Community), the above applies as well. Do not use any UiPath.UIAutomation.Activities with version less or equal than 18.3.6864.20582 and UiPath.Core.Activities with version less or equal than 2018.3.6864.20598.

Please feel free to create a new Technical Support ticket for any further issues, we will be glad to assist you.

Hi @Duane_Higham

Thank you! I’ll try that. I was suspecting something like that because the process I was trying to run threw an error at the Open browser activity but another process that’s not using any browser activities works fine.

I was facing the same problem.
I just did ctrl+P and updated the version of all activities package to the latest versions. and the error was gone. :slight_smile: