Problems with running robot on VM

Morning All

I have created a simple process of logging onto a website, navigating to different customer pages and updating information etc.

This all works on a local machine and works on the VM when started through the agent.
When I use orchestrator to start the Job it faults at the below.

Saying it cannot find the css selector

  • Process: alteryx_2
  • Environment: DemoBots2
  • Robot: DemoBot2
  • Info: “Execution error : UiPath.Core.SelectorNotFoundException: Cannot find the UI element corresponding to this selector: <webctrl css-selector=‘body&gt;div&gt;div&gt;div&gt;div&gt;div&gt;div&gt;div&gt;div&gt;div&gt;div&gt;div&gt;div&gt;div&gt;div&gt;div&gt;div&gt;div&gt;div&gt;div&gt;div&gt;div&gt;div&gt;div&gt;input’ tag=‘INPUT’ type=‘text’ /> —> System.Runtime.InteropServices.COMException: Cannot find the UI element corresponding to this selector: <webctrl css-selector=‘body&gt;div&gt;div&gt;div&gt;div&gt;div&gt;div&gt;div&gt;div&gt;div&gt;div&gt;div&gt;div&gt;div&gt;div&gt;div&gt;div&gt;div&gt;div&gt;div&gt;div&gt;div&gt;div&gt;div&gt;input’ tag=‘INPUT’ type=‘text’ />\r\n at UiPath.UiNodeClass.FindFirst(UiFindScope scope, String nodeID)\r\n at UiPath.Core.UiElement.FindFirst(FindScope scope, Selector selector)\r\n — End of inner exception stack trace —\r\n at UiPath.Core.Activities.ScopeActivity.OnFaulted(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)\r\n at System.Activities.Runtime.FaultCallbackWrapper.Invoke(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)\r\n at System.Activities.Runtime.FaultCallbackWrapper.FaultWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)”
  • Start Time: 2018/09/12 9:17:19
  • End Time: 2018/09/12 9:18:u5408: