Problems with recognize a VPN

uiautomation
studio

#1

Hi everybody, Im looking for an answer.
Im triying to automating a VPN connection, but UiPath does not recognize the boxes where i have to introduce the credentials

Foto%20duda%20UiPath

I tried all the possible ways, diferents types of records (Simple, Desktop, Web & Citrix), with single actions (click, type into, hover, etc) and it didnt work anyway.
The records dont allow me to select the boxes where i have to fill with the credentials, when i press “select into screen” the software does not recognize the boxes. Same history with the singles actions.
Also i tried with the selectors (using UiExplorer) and it doesnt work neither
Someone can help me please
Thanks for your responses.


#2

sometimes the selectors simply can’t be seen by the uipath software.

Have you tried anchoring using the text on the left? So anchor to “Server” then type into the area to the right of it, and so on?

It’s a little easier for the buttons, as it can just find the location of the word “Connect” and click that location.


#3

Hi Dave,

Thanks for your response, i tried everything, but the software does not recognize the window of the vpn, so i cant do anything with that window. Another suggestion?

Thanks for the time!


#4

So UiPath can’t even attach the window of the vpn? Is that what you mean when you say it can’t recognize the window of the VPN?

What if you use the open application activity to start the VPN, then output that window as a variable, then provide that variable in an attach window activity?

Then within that attach window activity you can use the various image based screen scraping techniques mentioned previously

EDIT: Just to be more clear, I do understand that Uipath cant find the input text boxes. My earlier instructions were to use either the Find OCR text position activity, or the Find Text Position activity to find the clipping region of the words to the left of the text boxes (Server, User name, Password). Then, you can use that as an anchor and type into the region just to the right of that.


#5

Hi.
I had typed a possible workaround but got pulled away for a few hours.

Just as a workaround you could use all keystrokes with TypeInto activity.
If you use an empty selector it should Type into the whole screen.

The type into string would look like this:
```TypeInto “username[k(tab)]password[k(tab)][k(enter)]”````
You can also break each action to different TypeIntos or all in one.
Selecting the Server might be harder if it’s not the first active element, but a “[d(shift)][k(tab)][u(shift)]” will do a reverse tab keystroke.

Regards.


#6

Yes, i cant attach the window of the vpn.

Open application does not work , its an app who need administrator permission, and actually i dont know what kind of variables could be on window Variable.
The OCR does not work either.

Thank anyway!


#7

Can you describe what you mean by it needs administrator permission? Is there a popup that happens when you open it?


#8

Hi ClaytonM

Thanks for your interest and your answer, but the action “Type Into” does not work either. I cant attach the window of the vpn, so it does not recognize the singles actions.
I tried with an empty Selector, but it does not work either.

Regards!


#9

Actually yes, but i put the option that always open as Administrator, so it open normally, but no one single action works


#10

Can you try this?

  1. Create shortcut of the program (right click the .exe --> send to desktop)
  2. Right click on the shortcut
  3. Navigate to the Compatibility tab
  4. Click the checkbox that says “Run this program as an administrator”
  5. Click ok

Now, use the open application activity and in the filename property, insert the filepath of the shortcut you just created. This should open it with admin rights. You should also create a variable of type Uipath.Core.Window. Update the output property of the open application activity to this window variable.

Now, supply that window variable to the Input window property of an attach window activity.


#11

These 2 options have also been tried in UiExplorer?

image


#12

Hi Dave

I tried what you said, but it didnt work, i get the following error

Selector%20Problem

This is the FileName: “C:\Program Files (x86)\WatchGuard\WatchGuard Mobile VPN with SSL"
And this is the selector that im using:”"
Because de attach window, does not work either

Regards!


#13

Hi vvaidya

Thanks for your response, but yes, i tried and it doesnt work :frowning:

Another suggestion?

Thanks for your time & your response!


#16

Hi Guys,

Is there any way to directly send the login request as like a web service request instead of using the vpn connect application.


#17

Hi,
Did you find any solution for this?