Problems with Citrix Receiver and Attach Window

I’m automating application (our ERP system) that is running on a Citrix server. I have a Citrix receiver 4.9software installed on the Windows Server 2016 server, which also has UiRobot.exe and it is running my xaml. I’m using the bat file to start the job at a certain time.

So this task goes like this:

  1. Open the Firefox browser
  2. Go to specified URL and click the link which starts the Citrix app via Citrix Receiver
  3. Wait for the login window, enter the username and password and login to ERP system
  4. Run a task in this ERP system
  5. Log off

This whole task works mainly like a toilet of a train except the phase 3. I am using the Attach Window function in it. This attach window has a selector which has a value:

wnd app=‘wfica32.exe’ cls=‘Transparent Windows Client’ title=‘Sisäänkirjautuminen system1 - \Remote’ /

About 2 of 3 Attach Window function runs are failing. The robot is just waiting for the window to appear but I can see with my own eyes that this window is on the screen and I can see that this title is ok. There is also only one wfica32.exe running on the machine.

This “sisäänkirjautuminen” is a finnish word and it means “login”. I have also tried the selector with the wildcard marks if the letter ä could be the problem but it doesn’t change the situation. Like this:
wnd app=‘wfica32.exe’ cls=‘Transparent Windows Client’ title=‘Si*kirjautuminen system1 - \Remote’ /

I have tried this also with the UIExplorer and I can repeat this problem. If I open this login window with Citrix Receiver and go to UiExplorer, then I’ll make this selector and test it, sometimes the UiExplorer says that it can’t find the login window with the selector but sometimes it can find it even if the window is on the screen all the time and I’ll just test it with UiExplorer many times. Is there some kind of bug with these selectors?

How could I do this without the Attach Window function if it doesn’t work with Citrix Receiver?

1 Like

Did you ever find a solution to this issue? I am experiencing a similar issue. It was working fine when only running the Citrix Instance within a Web Browser, but once I transitioned to a standalone instance of the Citrix Receiver, it is like it cannot find nor attach to it. I noticed in the Task Bar that the Citrix Icon just flashes for a few seconds and then the Automation times out. Any ides…?

1 Like

I am facing similar issue in Unattended execution with Citrix receiver. Based on the screenshots that I’ve taken for logging purpose, I see that on click of any app icon in Citrix receiver window, the wfica32.exe window is not launched atleast it is not seen in the foreground. I tried using an Attach window with selector wnd app=‘wfica32.exe’ cls=‘Transparent Windows Client’ title=’* - \Remote’ but there is an exception that window does not exist. I am using UiPath v2018.4
Note:We will install UiPath’s Citrix Runtime Component installed on Citrix server in the near future, but I am curious to understand if the current behavior is a known issue or some programming flaw.

1 Like