Problème UiPath Level 3 Exercice 2 - TransactionItem

Bonjour,

Je rencontre un problème lors de l’exercice 2 du Level Avancé pour UiPath (Level 3).

Après avoir suivi la documentation, lorsque je lance (Run) sur UiPath Studio, voilà l’erreur qu’il m’affiche.

J’ai pourtant bien vérifier le type de variable pour TransactionItem.

Merci pour votre aide.

You have to change all instances of TransactionItem to DataRow from QueueItem in the whole framework.
You will be able to fine the section where this change is required by searching for the blue indicator :large_blue_circle:

Vous devez modifier toutes les instances de TransactionItem en DataRow à partir de QueueItem dans l’ensemble de la structure.
Vous pourrez affiner la section où ce changement est requis en recherchant l’indicateur bleu :large_blue_circle:

Merci beaucoup Nadim.

J’ai une question concernant le lancement du Robot.

J’ai malheureusement inséré un nom d’utilisateur et mot de passe “faux” pour tester.

Je n’arrive plus à le modifier.

Pourriez- vous m’aider ?

Merci

Si vous n’utilisez pas l’actif d’orchestartor et que vous avez entré l’option alternative de la fenêtre contextuelle
alors je vous suggère de rechercher Credential Manager dans votre StartMenu, cliquez sur Identifiants Windows et recherchez Acme Credential avec admin / ******* et supprimez-le.

Laissez-moi savoir si cela fonctionne.

If you are not using the orchestartor asset and you entered in the alternate pop-up option
then i suggest you search for Credential Manager in your StartMenu click on Windows Credential and search for Acme Credential with admin/******* and remove it.

Let me know if it works.

Bojour Nadim,

Le problème vient effectivement de “gestionnaire d’identification” dans Windows.

Il faut modifier ou supprimer les différents compte déjà présent.


J’ai continué mon aventure sur UIPath et je reste bloqué sur l’Exercice 2 “Dispather”.

Mon robot se lance, se connect à ACME, ensuite sur l’onglet Workitems et il ne parcours pas les pages pour enregistrer les valeurs.

Voici une image

Pourriez m’apporter vos lumières ?

En vous remerciant !

Mon project en pièce jointe

REF_2.zip (2.0 MB)

1 Like

Bonjour,
Donc, je vérifie le processus et voici mes premières conclusions.

  1. Votre GetTransactionData.xaml n’est pas structuré correctement. Vous devez avoir le chèque avant le ElementExists

  1. Le sélecteur de ElementExists doit être dynamique (c’est-à-dire qu’il devrait changer pour chaque transaction afin qu’il passe à la page suivante et jusqu’à la dernière page.

Sélecteur de courant:
image

Sélecteur requis (dynamique):
image

  1. Changement similaire, vous devez ajouter dans le Process.xaml pour le Click et ElementExists.

ous pouvez vous référer au fil ci-dessous pour plus d’informations:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.