Problema Certificados SILTRA / Digital Certificate Issue

Buenas, estoy automatizando un proceso en SILTRA. El problema viene en la pestaña de elegir certificados, que no aparece. Si hago el proceso manualmente, todo funciona correctamente. Si lanzo el robot (que sigue los mismos pasos), dicha ventana de elegir certificado no aparece.

No entiendo a qué puede deberse esta diferencia de comportamiento y cómo abordarla. Si a alguien le ha pasado antes y pudiera darme una solucion, estaría muy agradecido.


Hi everyone,

I’m developing a process in which the robot has to work with a desktop application which need a digital certificate to access. When I follow the steps manually, everything works propperly, but when I run the robot, the window where the digital certificate should be selected, does not appear.

I cannot understand why if the steps are the same, the behaviour is different when the robot runs. Could you help me?

Thank you so much.

Hola @ajgb !
From your explanation, my guess would be to double check the selector that you are using in your automation. It may be that it not actually clicking the button to launch the page where the certificates are, but it is not throwing any error. This is common so I would double check that your selector is robust enough. The other thing to look into is timings. Robots run at different speeds to humans so you may need to consider adding delays to ensure it is not running too fast for the application.

Please try these options and hopefully you will get a resolution.

Buena suerte!

Hi @katharine.hardy, thank you for your answer.

I have tried adding delays before and after every click, but still does not work. The application does not allow SimulateClick neither SendWindowMessage as input method. The selector is correct and robust.

A very few times the window with the certificate has appeared, but even when the same click configuration there is not predictible behavior.

When the process is executed manually, the application is complete stable and its behavior is correct.

Hi @ajgb
Potentially the next option is to add validations and retries around that particular action. If it works sometimes but not always, retrying could be your best bet. How often does it not appear?

From my experience, it is rare that it would work so perfectly manually and so unreliably with automation if your selectors are robust :frowning:

What type of application is it? Can you share the selector that you are using for this click?

Hi @katharine.hardy,

I cannot add any validation or retry, because the windows disappear once the robot click the buttom.


When I click in “Conectar”, then the certificate window should appear, where I choose the certificate and then press OK

The application is a desktop application which require a digital certificate to work. This is the selector of the buttom “Conectar”:

<wnd app='wsafilia.exe' cls='ThunderRT6FormDC' title='Afiliación (Adaptación del fichero)' />
<wnd aaname='Conectar*' cls='ThunderRT6CommandButton' title='Conectar*' />

There is no problem with that, because the robot click on it correctly. The problem is that the next window doesn’t appear.

Thank you