Problem with version increment number after publishing an automation

Problem with version increment number viewable in Assistant. Not a showstopper but annoying.

Running (testing) the published version you’re told, you’re running an outdated version which actually you do not!

Moreover, when publishing an automation only the first time you’re ask to install it in Assistant, apparently not always! Or there seems to be a time frame you need to re-install the last published package or Assistant looses information while publishing packages within a timeframe? I tried to publsh improved automation, I did not need to re-install them but the last one published seems to be installed but the information told me otherwise!

UiPath Studio ↔ Assistant
Version_Increment_1

The following screenshots are self explaining

Hi @van-der-kamp ,

Thanks for reaching out.

Can you check if after publishing your code you have upgraded the version in Orchestrator to the latest Version?

image

If not try to upgrade and check.

Hope it works.

Happy Automation,
@Vinit_Kawle

1 Like

@Vinit_Kawle hoi! In Orchestrator (Processess), my automation seems not to have the latest version published. Now I’m confused. I did yesterday evening small textual changes (after the booked version 1.0.11) to figure out what is going on.
I re-published 3 times, to me version 1.0.12, 13 and 14 one after each other. Each time I did not see the version number being upgraded in Assistant.
I ran it from Assistant, as I though they were upgraded below the surface (I did not check the version on the Processes tab in Orchestrator.

However, I am almost sure I did see those small textual changes. Apparently not, now I am not sure anymore. Did I really see them? Those small changes? I’m asking myself what were those small changes. To me small textual stuff, I though I did, but can’t prove it though. Orchestrator now tells me otherwise… …perhaps too much :cookie:-‘pepernoten’-:cookie: kind of small cookies, because it was ‘Saint Nicholas (the Dutch :santa:) and soot smear-Peter’ (the Dutch ‘Rudolf’ :deer:) night at home.

No, in Orchestrator, I am not able to upgrade to the latest version,

  1. not on the spot you suggest
  2. not on spot

Hi @van-der-kamp

Make sure when you publish you give the name as per given in the orchestrator process. Then it will show the Latest to Upgrade option.

Hope it helps!!
Regards,

@Parvathy, I did not change the project name, neither in Studio nor in Orchestrator. Easily viewable on the screens!

Hi @van-der-kamp,

Can you check you are connected to the Coorect folder where you publishing?

Hi @van-der-kamp

Make sure you are connected to right folder and to the correct feed.

Regards,

@Vinit_Kawle @Parvathy see


Did not change those names either!

I was able to publish and test previous versions and test those from Assistant (let’s call Assistant a sort of frontend of Orchestrator). But, as said, I did notice at least one time earlier last week, not able to re-install a just published package in Assistant !

Did not change a feed name or whatever thing, label, etc., anything exterieur to the publishing package !

Hi @van-der-kamp ,

Can you check for the Package name that you publishing?
image

Is there any change between the last publication and the new one?
Maybe the Package name has been changed and you published it in the right place but with a different Name.
Can you cross verify in Package as below

Hope this works!!

Happy Automation,
@Vinit_Kawle

1 Like

@Vinit_Kawle @Parvathy

Dear guys, believe me, I’m not fooling around, I don’t dare !
I did not change any name, package name, folder name in Orchestrator, etc., etc,…
…but, I did do something else! Trying to tackle this :poop: !

Let me explain! Let me order the steps taken! Seems to be a workaround (for me) !
Hopefully not for others!

  1. Added an extra message box in the State Initialize of the project. Just to see if this ‘adding’ is viewable after the next ‘publish’ action.

  2. Published the project to version (1.0.16)

  3. Did not see this latest version in Assistant, also not after refresh. The published version kept sticked to version 1.0.11. Also not able to do a re-install !

  4. Decided to delete the published version (1.o.11) from Assistant. Also checked Orchestrator. As expected, the published package (1.0.11) on tab [Automation > Processes] was gone!

  5. Went back to Studio and re-published again, it became version 1.017 !

  6. Reopened Assistant: surprisingly did not see the latest published package, nor after a refresh (on which I expected to be able to do a RE-install) and also not in Orchestrator.
    So, only delete of the currently installed package did not do the trick. What to do next?

  7. Decided to log out of Assistant and trying to re-log-in !

  8. Still no option to install a package (expected to see package version 1.0.17, other project packages still available ! Now what?

  9. Went back to Studio and republished again, now I got version 1.0.18 !

  10. Again logged out from Assistant which also logged me out from Orchestrator (as expected).
    12 Re-logged-in into Orchestrator and Assistant, saw the javascript message, but still did not see, package version 1.0.18 !

  11. Went back again to Studio and decided to RE-RE-publish, I got version 1.0.19 !
    Apparently it seems to be needed to be disconnected from Assistant (and Orchestrator) when publishing.

  12. Opened Orchestrator > finally on the [Automation > Processes]-tab (My Workspace-folder, not the one containing the Assets and Queue for this REFramework project), I saw an extra package. Yippee! Meaning it must be available in Assistant as well !

  13. Opened Assistant, refreshed, and… …yess, there it was!

As said, I did not change project name, folder name or any other exterieur label (only added an extra message in the automation). Logged-out and logged-in again, RE-RE-RE-published; finally got version 1.0.19 (as a new package able to install).
16) Installed this latest package (version 1.0.19) and ran it!

![Version_Increment_16|690x325](upload://5mbtLqugX21yUmZ3n7rePBfq3IH.png)
  1. Conclusion: It seems necessary before each ‘publish’ action

Log-out deliberately from Assistant and Orchestrator
Publish
Log-in into Orchestrator and Assistant
Refresh Assistant
Install latest publication
Test latest publication

I don’t understand why ! To me it is not a solution simply a silly workaround caused by ‘something’, I don’t know what!

Stupidly, now I have to do the whole thing again to get rid of that message box, uhm!

RE-publish from version 1.0.19 to version 1.0.20 !

Before clicking the [OK] button on the message ‘Successfully publish’-action, sailed to Assistant, logged-out deliberately; meaning also being deliberately logged-out from Orchestrator (had that web page open on the back).

So, need to manually log-in into Orchestrator again, seeing that javascript message saying connection with studio, but before opening tab [Automations > Processes] went again to Assistant. In Assistant, however did not see he option to re-install but now one way or the other the latest published version was installed (change to version (1.0.20). Double checked it in Orchestrator, and yes, also on the page [Automations > Processes] I saw this latest version.

Finally went back to Assistant, ran the latest published version, expecting…
…yes, the ‘Test’ message was gone! Not a solution, the best ‘a worse work-around’!

Still, do not understand, why I need to logout from Assistant after a publish action?

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.