Problem with uploading "yearly reports" to ACME web site in Assignment No.2


I’ve been trying to finish the “Generate Yearly Reports” assignment. The part where the robot uploads the yearly report (xlsx) file fails (as shown in image below.) I don’t think the problem is on my end. I couldn’t upload it manually either.

Resetting test data, as many suggests, did not help. I reset, and rerun the whole workflow about 13 times already. None worked.

Is it a problem with the year being 2018?


Please reset the data before uploading the reports.
If you try to re-upload, then you will get this error.

I already did so. It doesn’t work no matter how.

After resetting the Data in ACME System 1, you must clear your Queue - InHouse_Process4 also then run the Dispatcher again before the Performer, if you continue to run the Performer after resetting without running the Dispatcher first it’s either you will not get records for all months or will continue to get the same error because when you reset the reports changes.

I’m running a custom workflow. It’s not the REFramework. It resets everything automatically.
The question is, even if everything is wrong, shouldn’t it upload an xlsx file?

Funny thing is that I changed the file name to Yearly-Report-2017-RO657483.xlsx and it uploaded.

As long as the Yearly report was created even with only one month and the other months failed to download, the upload with take place because what if check is that the Yearly report for a download Tax ID is available then it upload it. But if there is no report in the Temp folder it will throw an error. When I was doing mine somehow other months were failing to download but that didn’t stop the workflow from uploading the Report until I make sure that whenever there is a fail download, there should be a retry of the download process.

My workflow doesn’t have a problem with downloading monthly reports, and merging them into one xlsx file.

It’s the website that doesn’t accept a perfectly fine, properly named, and existing Excel file.

Try to delete your Queue and add it again in Orchestrator and Reset test data then run your dispatcher and your performer

You should upload the file only once. If you try to upload it again you’ll get an error message (Some problems were encountered). It worked second time because you changed the file name, so it didn’t existed before.

For the record, when you get the error message “Some problems were encountered.” when you try to upload the yearly report, you should make sure that:

  • Report File is selected;
  • Vendor Tax ID is set;
  • Year is set;
  • You have not previously uploaded a file with the same name for the same Vendor Tax ID.

Those above are the checks to trigger that error message.

1 Like

That’s exactly what I suspected before and most probably it’s what happens.
Now I’ve got to figure out how it double clicks the upload button. (Because I’m sure that I set it to click on “upload” button using left mouse button - once.)

I’ll post an update once I solve the problem.

Having the same issue here… Did you find out where the issue was @DEMIR ?

The problem was the robot clicking on upload button twice. I am 100% sure that the click activity wasn’t the problem.

I suspected there was something to do with the “for each” loop I implemented. So I removed whole web activity out of the loop, and rewrote that part of the workflow. It worked.

Yet I still think that it’s probably something else.

  • My workflow was like this:

Download CSVs
For each vendor(
Merge a vendor’s CSVs into one xlsx file (yearly report)
Upload report

which means it goes like this: Merge and Upload - Merge and Upload…

  • Now it’s like this:

Download CSVs
For each vendor(
Merge a vendor’s CSVs into one xlsx file (yearly report)
For each report(
Upload report

with that it goes like Merge Merge Merge Merge… then upload all of them one by one.

My suggestion: Create a separate workflow for that part of the assignment and test it. Make sure it doesn’t click twice and that you can scrape the ID on the pop-up.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.