Problem with UiPath robot and firefox

Hello All.

I need help in understanding the Strange behavior that is occurring with the UiPath studio and Firefox Web browser.

Configurations -
Operating system - Windows Server 2012 R2 Standard 64 bit
Firefox version - 62.0 - 64 bit
UiPath studio version - 2018.2.3 (Enterprise edition)
UiPath addon version - 9.0.5993

There are two Virtual machines with me, both having the same configuration as stated above. On machine 1, while developing the UiPath studio is able to identify the elements in the web browser. But, while doing the same on Machine two, it is not able to identify the same element.

Machine two -

can anyone explain this strange behavior?


Secondly, when I am running a process from Orchestrator on both these machines,
An error ; “System error at initialization: Cannot communicate with the browser, please check the UiPath extension. at Source: Invoke Accounts workflow: Open browser” is occurring on Machine 2 but it is working fine on Machine one.
I suspect the first issue which I stated is causing this problem.

Any help will be appreciated. Thank you .!

Screenshot of the same on Machine One -

The screenshots represent me trying to hover over the cloud icon of salesforce. And the UiPath Studio is identifying the elements differently.

I hope I am conveying my problem with clarity. Any help will be appreciated…
Thanks again.


Have you tried to install/reinstall Firefox Plugin on the Machine #2?


Hope it Helps :slight_smile:


I reinstalled it Lucas.
The error remains the same.

The two machines has the Firefox 64bit? It’s possible to install Firefox 32bit instead?

Lucas - I tried it in 32 bit as well as 64 bit. it is not working.

and yes, firefox is upto date.(at - 62.0 version)