Problem with start process activity

Hi all,
i’m in this situation, i’ll try to start pdf file in my 20_invoices folder that is in the same folder of main program (the file name are Invoice 1-2-3 etc.)


When i start the robot there is an error Source - Start Process Impossible to find the path/file, would you mind helping me?
If i replace the first quote with file.tostring it open all files.
Thanks in advice

Can you check what you are getting in the variable file there? @andreus91

You will get the entire path there? I don’t understand what are you trying to do in the starting process without file variable?

1 Like

Hi @andreus91.

In order to start your process you’re going to need to add the file extension to your process name something like…

“20_Invoices\Invoice” + counter.tostring + “.pdf”

But I don’t see what you’re doing with the “file” For Each variable. Can’t you just use it in the Start Process?

HTH

Troy

1 Like

Also with this string “20_Invoices\Invoice” + counter.tostring + “.pdf” is the same, i’ll try to open the file passing the file name.
scruii2

You got it. …and you shouldn’t need a counter that way.

1 Like

I don’t need a counter yes but the file name are Invoice 1, Invoice 2, Invoice 3, so the counter represent the number after the name of file… But still the same issue… How can i fix it?

These are variables

A post was split to a new topic: Installation has failed when installing Studio

Missing the backslash \ and +".pdf" now it works.

Thanks :smiley:

@manik_garg

please open a new thread I´ll be more than happy to help if you tag me.

however this post is regarding a totally different topic and in order to maintain the quality of this awesome forum we will have to follow some guidelines.

Excellent!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.