Problem with dropdown list

Hello!
I have a problem with dropdown list. It behaves very weirdly.
Here is an excel with dd list:


I need to click on the second dd list and select there “Select other…” to get recieve the next window like :
.

My workflow looks like this:
uipath

What the most weird is - when I use first two activites (click and select item) - it always opens reequired window (pict #3). But when I join any activity furher - it stops on clicking by “Select other…” in dd menu.
I tried many ways with different activities and with checking element exists. It always stops if there is an activity further.
Has anyone experienced such?
Thanks

can you post the selector here?

@AndyMenon, sure
1st activity click:
Click1

second activity select element:

Third attach window with click:
atwind

Attach window:
attach3

Click:
click4

You see why it works. That’s because the selector has hard coded values for your selection.
When the selection changes, it wont work because your selected value wont match the hard-coded value

You have to give remove the hard values and replace them with parameters. Something like this
ctrl name = '* children' ...

and

ctrl name = '*' role = 'text'

@AndyMenon,
Selector that you mention i want to use as a parameter, but further.
At first i need at least to get this window opened , at second click on this selector that is chosen (the one you mentioned)
But currently robot doesnt open this window after clhoosing one in dropdownlist.

Can you try to alter the highlighted attribute and test?

image

@AndyMenon,
Tried all options in “wait for ready…” - no success

Did you experiment with Attach Window Vs. Open Window?
Maybe you will need to open that window explicitly before you can make a selection

@AndyMenon,
As you see i tried attached window- no success. Open window - i havent tried. I’ll try it. But i think it won’t let me open this window directly without clicking erm dd list. I will update you when i try. Thank u

@AndyMenon,
There is no activity in activities - Open Window.
Attach widow, as said before - no success…:neutral_face:

Sorry @Slavich,

I’m trying to scratch my brain on what else might be the issue.
Would it be possible for you to use the Hot Keys Up and Down to make selections and see if it works.
If not, you may have to post a video recording of this thing in action.

@AndyMenon,
I tried with hotkeys. It doesnt open me window when I choose what I need in dd list.
The video is attached how it works manually in first video(first time I click with mouse, second time - trying pgdown…)
In the second video how it works with uipath (It opens window when I run first two activities, and when I add third - it stops working)


@AndyMenon ?

Guys, help me please

Hi @Slavich,

Sorry, I barely got time to work on anything over the weekend. I’m at work right now. I will try to look into it over lunch and see if I can help.

I hope other members of the community have some solution as well.

Ok, from the Second video, what I understand is that the Robot makes the “Select other members” selection from the drop down list.

But it does take take time for the Excel pop up dialog to show up after you make the first selection.

Which means that you have to tell the Robot to Pause until the second window shows up, and then use the Attach Window to proceed further.

image

From the video, I see one other thing when you’re using Attach Window. The title of the window says ‘Excel.exe EPM’. But the Robot doesn’t seem to indicate any error. This tells me that the Attach Window is attaching itself to the outer Excel window, running that activity and completing the process successfully. One way to confirm this to check your output tab and you will not have any errors.

image

The workaround to this is to come up with a selector that identifies the second window that you’re using in the Attach Window activity.

I hope this helps.

Thank you @AndyMenon.

  • i tried also with delay activity. It didnt help.

Thanks again. Tomorrow while being at work I will send selectors.
Anyway it really weird because when it click on dd list and opens EPM when “select item “ is the last activity. So it should also open EPM when I add activities after “select item”, but it doesnt…

@AndyMenon, I played with selectors of attach window - no result. It looks like select item activity doesnt proceed click on “select other member” at all.

Would it be possible to change the approach itself?
Instead of using Select Item, how about you try using Click activity. The selector for the click might have to be a VB Expression

Sorry it’s really tough for me to resolve this without my hands on the steering wheel :disappointed:

@AndyMenon,
With several Clicks, Hover, Attach window instead of Select Item it also doesn’t work…

What do you mean ? How is it look like?

If it is posible we can arrange video call in order you can see the screen? Thank you