Problem with Chrome (scraping, find text.. and other activities)

Hi to All,
I have a compatibility problem between Uipath and Chrome that does not correctly recognize some elements, so I am unable to proceed with the processing.

My job requires that I access a screen of the Celonis tool, perform a scraping and start a series of cyclical processes by entering each element.


The main page contains a list of elements (boxes).
I should go into some of these, starting with a list I provide at the beginning.

ex:
I would like to click on: PRO - OB WL VULA v1 (old) the first box.
No command work: Find Text, Click Text …

I tried to extract the data, as a table, but it doesn’t recognize the elements as a table.
I can do a Screen Scraping Get Full Text ‘DIV’ getting this result:

Concatenated elements.
I don’t know how to separate them to create a table.
I thought to use the visible name, to click on the corresponding element, but anyway, the “Find Text” doesn’t work
I don’t know how to fix. Has anyone had similar problems?

Thanks a lot…
Aaron…

Hi @AaronMark,

Have you tried Find children activity on this page and then go through each to access them(using click activity)?

Also for concatenation, split function should work to split the values.

Regards
Sonali

Just use the Click activity, not Click Text nor Find Text.

Hi sonaliaggarwal…

I have never used this activity.
I am not an expert … This is to be premised.

I shared the flow to let you understand what I detect as Element, Tag … Selector … etc …
Main.xaml (109,0 KB)

I recycled a stream that I found on the forum.
I do not know the commands I have set, but with a Write Line, I was able to write the list of my KEYS from premese. (which I must enter).

I would have to click and enter on each of these elements to perform operations.
The name and number of “boxes” is variable.
Actually, the “nice to have” would be to create a datatable with the list of names that I am interested in intercepting.
Then, click on the names plotted in this table.
To do this I was thinking of using a Find Text but it doesn’t seem to work.
If you have / have any advice … I am happy to receive it! :slight_smile:

Thanks a lot…
Aaron

Hi @AaronMark,

Could you try following:

  1. Use find element activity (should be somewhat as shown below):
  2. Loop through the result (listChild) shown in this case.
  3. And include click activity in loop itself to click on element (e.g listChild(0))
  4. carry on all the operations you want to with first element found
  5. Repeat the same with other elements/boxes.

As you can have different number of boxes and their names, I think this should solve your purpose.

Alternatively, you can try finding the relations between selectors of these boxes, once found loop until element exists if false. Once false, exit from loop.

Regards
Sonali

hi Sonaliaggarwal,
thanks for your invaluable help.
I think I am a little closer to the solution, but not yet.
I followed your instructions. (I believe).
This happens:

  • I position myself on the page with the boxes where I have to enter.

  • Find Children (descendant) Output = ListChild

  • For Each Item in ListChild >> CLICK “listchild(0)”
    image

Initially it seems to be fine. The cursor enters the first box.
Then I go back to the list, but the cursor clicks on link: "PRO - OB WL VULA (Alberto)
Out of any box.

image

What can it depend on, that you know?

Hi @AaronMark,

Looks like that part is also being captured as children.

Can you try printing list elements in loop and see how many children were captured by find element, this will give us an idea on what’s happening and what do we need to tweak.

Regards
Sonali

I don’t know how to print, each UiElement… :expressionless: sorry… :expressionless:

image

I noticed that, although the area collected with the shot contained only the three panels, the “elements” he tried to write are over 20
39 to be precise

Hi @AaronMark,

Can you share which element you selected in find children activity?

I think you have selected some top level element which is why all children are being selected.

Can you try changing that selector to “Process data models” and see?

Regards
Sonali