Problem with building an unattended bot with mouse actions

Hello, everyone,

i’m trying to develop an unattended bot.
The bot must click on an element in a software. When I try to click with “SimulateClick” or “SendWindowMessage” option activated, I get an error in studio saying “Click: Action not supported by this type of element. Please use another type of click.”

Is there a way to solve this? If I use the default mouse type it works but it is not possible to develop an unattended bot, isn’t it?

I tried “click image”, also because I read that as a solution sometimes here in the forum. But that isn’t a solution in my case, because the text for the selector differs.

Greetings
Johannes

@johannes.kusber
Simulate Click, SendWindowMessage are building blocks for background interaction. A “normal” click doesnt conflict with unattended bot. So give a try

This message typically occurs when something other than Single Click is used with SendWindowMessages or SimulateClick. If you’re double-clicking, you can use a loop to use a single-click activity twice in succession. Just make sure the delays are minimized on the click activity.

However, if you’re using Right Click, you would have to not use SimulateClick or SendWindowMessages.

Thank you for your advise. I didn’t notice that “SendWindowMessage” and “SimulateClick” only works with single left click.

I tried your suggestion and used two single left clicks with no delay after the first and no delay before the second click. Unfortunately, the error message was still the same. Any idea?

Thank you for your input!

As I understand it, an unattended bot runs on a virtual machine in the background. Will the bot still work with the normal clicks?

I have tried it. But it only works if I have the VM open in the foreground (not locked). As soon as I leave the VM and start the process in Orchestrator I get a message “Timeout reached”. Am I doing something wrong?

Hello @ppr,

I found the solution! The problem was that I installed the community version. With this installation the UiPath Robot is not installed as a Windows service. So the default click only worked if the VM was open, because then the right window was in the foreground or the VM was not locked.

Now I have test the enterpriseversion. The robot operates now as a Windows service. Then the Orchestrator establishes its own RDP connection and the default clicks work too!

Maybe this difference in the installations/versions should be pointed out more clearly. I hadn’t heard that at the Academy either.

Thank you for your input!

@Anthony_Humphries: Thanks, you too! As mentioned above, I have also learned something from this. But it was not the primary mistake.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.