Problem with Bot running in background

Hello,
i need to run a robot via orchestrator and deploy it in a VM
I’ve already read it all to try to solve the problem.

I change the parameters of screen resolution in orchestrator
orchstrator
And all it seems to works fine without connecting manually in this machine…

I have only the same error, sometimes a click image (double click) fail, this command is inside a cycle so it works 1000 times and it failed 1 times, what can be the possible error?

I’ve tried to see the screenshot but i can’t see exactly what it can do, because after this command failed, it cannot be able to close this program and restart, so i think the possibilities are:

  1. The command click on another point of the program
  2. Something else happened in the machine (i’ve read windows open automatically the start menu) who interferes with the normal run of the BOT.
    someone who has had experience in such cases can help me?
    Thanks in advance
1 Like

Hi @andreus91

It looks like a simple error handling could solve your issue.

Are you by chance using REFramework to manage your process? If not, it would basically be able to catch your exception, restart your environment (or necessary parts) and then try again.

As a start, you can also use a simple Try-Catch to catch the exception and make a screenshot to see where and when does the issue occurs.

1 Like

Hi @loginerror,
yes i’ve used the REFramework to manage the process, and just seen the screenshot, my issue is with this double click with coordinate (i have a table that seems like an image) and sometimes failed, so i’m able to restart the process with the REFramework and i would do everything’s possible to avoid this problem.

1 Like