Problem Selector - loss of selector

Hello people,

I’ve been experiencing a selector issue for days, I’ve changed it in every way I could imagine, but still have the same issue.

Good,

execution opens the site
Login
Enter Registration Number
download the files

if you have any problem
he closes everything and picks up where he left off.

In this resumption, he ends up losing the registration number selector, I’ve tried using full, interactive selector … I don’t know what I do anymore

I tried with type into and setValue

selector 2
image

Try to replace:
“ctl00$MainContent$txtCriterioConsulta”

for
“*txtCriterioConsulta”

1 Like

Hi @Luis261980

Thank you,

I will test your tip

image

That way he didn’t find the selector

@KMota
There is a space before and after the *, remove those.

1 Like

no, --> *
will replace/read all in the name of the selector just type “*txtCriterioConsulta” no spaces

1 Like

Read this: https://docs.uipath.com/studio/docs/selectors-with-wildcards

1 Like

I removed the spaces and now it’s going,I’ll test to see if you won’t lose will not the selector. :slight_smile:

In the meantime I will read the material

1 Like

usualy when you have ctl00xxxx = ctl00 can change …

1 Like

Thank you, for now

@Luis261980
@DanielMitchell

1 Like

unfortunately the error still remains, in download recovery it does not find the selector

Can anyone tell me if it is possible to do an if type:

Selector = SelectorNotFoundException

true …
false …

this is possible or feasible because I can’t find another solution

Hi @KMota

If the selectors are dynamic, then for ease you can try the automatic Repair option when editing the selector.

Simply select the element once, then do the action that refreshes it and then try to repair it. It should automatically find the similarities between the two variants of the selector and come up with a stable one.

Hi @loginerror

Thank you, I will test as informed