Problem running Robot on AWS VM machine via Orchestrator**IMPORTANT

Hi Team,
I’m facing couple of error when I run my workflow via orchestrator on the VM (AWS) however when I run locally on laptop or by agent on VM its works perfectly fine. Could any one from UiPath or others can help me on this critical request?

  1. I have defined the “Get Outlook mail message” correctly however getting the error like - Specific folder doesn’t exist. Refer screen "Get Outlook Error"
  2. I have a web portal to register some data, so in the background it fill it up and when it click on “Send request” button , its keep on saving and also the screen appears not as expected. And giving error for selectors. Refer image "Web_Page_Error"
    Does anyone know, how we can overcome this issues in remote machine when it runs in background, also we have to do something with some setting or resolution or any other consideration?

@ovi @loginerror @ClaytonM or others? Can you please have a look and let us know?

When running from Orchestrator, you will probably want to set the resolution so the screen can fit the application windows better. You can set this up by going to Robots > Edit Robot> Runtime, and usually best resolution is width 1920, height 1080, color depth 32, with LogonToConsole False.

Also, some applications require that you maximize first before interacting (most do not though). There is a maximize window activity that you can use.

For the Outlook issue, first off, make sure you are using an updated Activity version. Secondly, if you have Enterprise version, you might need to use technical support

Regards.

1 Like

Thanks all!
I tried all the options but was not working.
However with the support from Technical team, I resolved this.
We can close this query.