Problem launching UiRobot from CMD for packages other than System and UI Automation

robot
cmd

#1

Hello everyone!!

In the last version 2018.1 I used to launch processes from CMD using the (uirobot + file path) command with no problem but when UiPath got updated I could no longer do this, there is another question on the forum that points out to the same problem but only for the excel activities.

I tried creating new processes and launch them to see if it is a compatibility issue, and for my surprise the simple processes have worked fine, but then I tried adding other activities and this time it got stuck with the same way as my old processes.

Till this moment I see that UiRobot from CMD works fine with activities from System and UI Automation but this is not the case for the other packages.

Finally I tried to publish my project then run it and IT WORKED!!! regardless of the package

I hope someone can give me a clear explanation, UiRobot should work fine from CMD without publishing, and this was the case for the previous versions.


#2

I solved this after a while the trick is to publish the process, this wasn’t the case for the previous versions but you just have to publish the process and then see it in UIRobot and you can pretty much access it from cmd or even use code that can interact with cmd and use it.