Preferred location is not getting clicked

I am having a strange issue in click activity When I click the Current Location activity it is easily getting a click and selecting the location. But when I click the Preferred Location it is throwing an error. I am have tried with the But none has worked.

  1. Click activity
  2. Type into
  3. used Send hotkey (tab) (enter).

in your selector i could see the aaName field can you please delete the same and include the class from the options and validate the selector.
if that still doesn’t work can you please send the screen shot after indicating the element through the uiexplorer

Looks like your selector is the problem there. Open it up in UI explorer and make the selector more dynamic.

Looking at the one you have, it’s probably because the name of the element has “Bangalore” in it and if anything the name of it should currently be “Choose” as that is what is displayed in the box. It looks like your ParentID may cause a problem further down the line as it looks like a transaction ID or something similar.

You can always try replacing part of the selector variable with a “*” to make it more dynamic

through Uiexplorer

You need to get that idx value down otherwise you will probably have issues automating on that element.

What other elements are available in the panel to the top right?

can you pls include the whole page or atleast the components of the right hand side included in the screenshot. because the idx and the isleaf has to be replaced with something which is in the right hand side list so can you pls include the same and update the screenshot

Pl find

1 Like

Andy, I have given the SS in the below link

Looks good now remove the idx and isleaf and select class from the list and validate the selector and then try highlighting the same using the highlight button at the top of the uiexplorer

You mean in this way

exactly does it validate.? and did you try highlighting the same does it highlight the same field which you wanted?

did That work?

it is validating but not getting highlight

its getting clicked somewhere

can you do one thing refresh the page and Indicate the element again and check what idx are you getting? share the full screenshot

pl find the element SS

Any solution ?

the idx remains the same try highlighting does it highlight?

Hey…it worked but how come the idx got changed earlier it was 14 but now it shows 12, I run the program it got selected the preferred location. Thank you very much. I was almost trying for 3 hrs. Any idea about the idx change. how did it happen?