Practical exam : Exptected acme_url and acme_credential configuration


I Failed to pass the practical exam for the “Role Based certification”. One of the Failed Criteria was:
check config file - config.xlsx for extra configurations for acme_url and acme_credential,
Can anyone tell me what they do expect to have ?
This is part my Config file:



Are you reading ACME URL from this config file and writing into your process or Hardcoded URL directly into your process ?

1 Like

I am reading from Config file. I am not using any harcoded value. I configured almost evertything in config! See attahced file.
Thanks for your help

Config.xlsx (21.4 KB)

1 Like

It would be great if someone can help… Is this config file right or wrong ?


Could you please check once again config file. I didn’t find any ACME_URL and ACME_Credentials in this.

I downloaded what I have shared. They are in settings sheet.


But I can’t find those in that settings sheet. Send me original file the one you used in the process.

tha attached one is the original file… I did not change anything. do you mind to open it and share a screenhot ?


Yes. Please share me screenshot.

Here it is… let me know

1 Like

Buddy @asafi
The issue is very clear and precise
the term implies the same as well

–we are trying to use a extra way of getting to the acme webpage with this input
Thats the problem, this is hardcoded isn’t it, that is we are mentioning the url to get to invoices page EXPLICITLY.

So to get this rectified, we have to remove this input ACME_URL_INV and wherever the URL value of this input is used we need to use a ATTACH BROWSER activity and need to handle the activities that are going to be performed within that browser page…
I hope this invoice page will occur on choosing the invoices option in the main tab of page, so it will go to a new browser page, where we will be doing some activities, while NOW WE HAVE TO USE ATTACH BROWSER ACTIVITY ONCE AFTER GETTING INSIDE THIS INVOICE PAGE AND INCLUDE ALL THE ACTIVITIES THAT ARE GOING TO BE PERFORMED OUT THERE

Simple buddy remove that ACME_URL_INV and use a attach browser activity to handle the activity in that page,
you were almost done
Hope this would help you
Kindly try this and let know for any queries or clarification
Cheers @asafi

Thak you for your reply.

Just to recap:

  1. Both ACME_URL and ACME_URL_INV are set in config file. So there is no Hardcoded values. Do you agree on this ?
  2. The ACME_URL_INV is used to access directly invoice page. What is wrong to have an additional configuration ?
    The alternative solution was to go to main page and then click on invoice search button. But I am using Chrome, and I noticed UiPath is not realy compatible with Chrome and in many cases you have to implement multiple workarounds to make a simple task (i.e. click OK on popup and many others).


1 Like

Fine, did the actual config file of a typical REFramework has this config variable ACME_URL_INV, no …do you agree on this buddy
Then how come its not a hard coded, we are mentioning directly the page within a web page to be accessed. If so why cant we do this for all the pages…that would be much better way of passing every thing in a config file right…!
Basically config file, can include only inputs that are given harded in the studio
well thats a good question

But thats not the right way to handle this situation in a standard template of REFramework while we have many workaround to handle this
See do we have a way to pass the url to a browser without this variable ACME_URL
No, only way is to mention this in the config file
Similary do we have a way to get to this url mentioned in the ACME_URL_INV without this variable, YES WE DO HAVE, and this is not needed at all right as we have got a exclusive activity called ATTACH BROWSER,

yes of course chrome is not compatible at some point of time with uipath,
but still we got another option, a stable and robust option which is what uipath also suggests, INTERNET EXPLORER, kindly try with that and remove that variable from config file and handle that with ATTACH BROWSER and try once buddy
This is what the actual reason for this
Hope this would help you
Still you feel not satisfied, kindly check once with the instruction before getting to the exam and also the typical config file of a REFramework, we wont see any such variable in it
Cheers @asafi

1 Like

Thank you for your feedback!

One additional Failure criteria was:
check for correct queue item properties with optimal usage

Do you know what is this related to?
PS: In the Dispatcher, I had to load in QUEUE, Invoice Number, Total and Date. In the Performer, I had to get Invoice number and Total.


1 Like

Make sure the queue name is same in both orchestrator and in your config file
and check whether the queue name is not mentioned in the studio directly without being from config
–Make sure the properties in the add queue items or get transaction item activity are mentioned with correct property inputs as per the instruction provided in the beginning of the exam, especially with these

Hope this would help you
Kindly try this and revert back for queries or clarfication
Cheers @asafi

This is what I stored in QUEUE

This is the Get QUeue Item

They did not ask for any specific things for the Queue. The QUEUE name is not hardcoded. You can see it in attached config file I shared at the begining of this post.


Another important point: They ask to store Invoice number and then to compare it with Invoice Item. Searching the forum, I see many people are raising this point but, If I am not wrong, no feedback from UiPath Team.
I did like everyone, I supposed it is a typo and compared with Invoice Number and not with Invoice Item.
Now I am getting the Failed Ciiteria: check for validation of correct items
Could it be possible the Robot is expecting Invoice Item instead ?!