Pending status while running a job in ui path orchestrator

When i create a robot and run a job manually on my personal pc the robot goes to pending status. I am not able to run the job successfully. Please help.

is any other Job running?
if not please try to restart uipathrobot and retry

I think I have the same issue. Just updated to v2019.2 CE on my laptop and on testing VM.

I already re-created a robot. Previously I removed everything from the orchestrator (robot, environment, machines). But, every Job I’m trying to create is set as PENDING… A few days ago everything worked fine on the same environment.

Now I’m removed v2019 and installed v2018.4. I tried to run simple robot which displays a message box. Execution faild with:

An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is:
System.Xaml.XamlObjectWriterException: Cannot create unknown type ‘{http://schemas.uipath.com/workflow/activities}MessageBox’.
at System.Xaml.XamlObjectWriter.WriteStartObject(XamlType xamlType)
at System.Xaml.XamlWriter.WriteNode(XamlReader reader)
at System.Xaml.XamlServices.Transform(XamlReader xamlReader, XamlWriter xamlWriter, Boolean closeWriter)
at System.Activities.XamlIntegration.FuncFactory1.Evaluate() at System.Activities.DynamicActivity.OnInternalCacheMetadata(Boolean createEmptyBindings) at System.Activities.Activity.InternalCacheMetadata(Boolean createEmptyBindings, IList1& validationErrors)
at System.Activities.ActivityUtilities.ProcessActivity(ChildActivity childActivity, ChildActivity& nextActivity, Stack1& activitiesRemaining, ActivityCallStack parentChain, IList1& validationErrors, ProcessActivityTreeOptions options, ProcessActivityCallback callback)
at System.Activities.ActivityUtilities.ProcessActivityTreeCore(ChildActivity currentActivity, ActivityCallStack parentChain, ProcessActivityTreeOptions options, ProcessActivityCallback callback, IList1& validationErrors) at System.Activities.ActivityUtilities.CacheRootMetadata(Activity activity, LocationReferenceEnvironment hostEnvironment, ProcessActivityTreeOptions options, ProcessActivityCallback callback, IList1& validationErrors)
at System.Activities.Hosting.WorkflowInstance.ValidateWorkflow(WorkflowInstanceExtensionManager extensionManager)
at System.Activities.Hosting.WorkflowInstance.RegisterExtensionManager(WorkflowInstanceExtensionManager extensionManager)
at System.Activities.WorkflowApplication.EnsureInitialized()
at System.Activities.WorkflowApplication.Enqueue(InstanceOperation operation, Boolean push)
at System.Activities.WorkflowApplication.SimpleOperationAsyncResult.Run(TimeSpan timeout)
at System.Activities.WorkflowApplication.BeginRun(AsyncCallback callback, Object state)
at UiPath.Executor.RobotRunner.RunWorkflow()

one more update. I created a new project in Studio CE 2018.4 (added only MessageBox activity). N=In this case it works without issues.

I’m also facing the same issue. :thinking: I have 19.5.0 and 19.4.2 UiRobot versions in my pc and tested with both. The job remains pending in orchestrator CE without triggering the process in the pc. If anyone has solved the issue please let me know.

Hi @Tharusha_Jayadeera

Please see this post:

As well as other posts about it here (each will have a post marked as a solution):
https://forum.uipath.com/search?q=job%20pending%20in%3Asolved

2 Likes

Hi @loginerror,

Thanks a lot for sharing the link. It worked for me.:slightly_smiling_face:

Regards,
Tharusha

1 Like