Pending jobs result in selector faults wich not appear when the jobs run alone

hi there community!
we have a problem with our processes startet with orchestrator.
If we force more than one job to run at the same time (which can happen when projects are live), we get a fault at least every second time it runs. but each of the jobs run stable when they run alone (scheduled in orchestrator) or run on testmachine startet from Studio.
the faults that occure, are always faults in connection with a selector. Some of them we could replace by a different solution, but there are always seem to appear new failures…! ( I know that sounds mysterious…)

for better understanding:
Job A is scheduled every 5 minutes in orchestrator: runs perfectly for at least 4 repeats.
Job B is scheduled every 5 minutes in orchestrator too: Job A faults every second or third time with a selector-failure AND/OR job B faults with a Selector-failure
JOB A is deactivated: Job B starts to run stable…

does this make any sence to you? or does anyone have any hint that will help us to find our mistake?

Big thanks in advance!

regards,
mohab

Would it be possible that 1 of the job fail to close a application that is used by the second process? So when the second process try to login in the application, it’s fail as it’s already open

Hi Maxy,
thanks for your reply. we had that thought to, and installed a “close all apps”-Procedure at the beginning in our processes. Also we logg, when a open process was found. So we can definitly say, that there is no problem with open windows or programms.
We also installed a delay AFTER every process, to make sure that everything is done, before the next process starts.Any other ideas?
regards,
mohab

Would it be possible to know what is the selector that fail? (clicking to open a program, enter userame/pass or anything else)

Does both processus use the same program?

Just trying to find out more to try to help out. :slight_smile:

thank you for your efforts! :wink:
the selectors were as easy as it can get: first we had problems with clicking a desktop-shortcut. We solved this with a change in the process, that is now opening the programm with the “start process” activity (which is the much better way anyway).
but now a different selector, which is neccessary to click through a menu in “ms dynamics ax” can not be found. we do not have a other solution for this, and honestly: i would rather like to know where the fault is coming from, then find a different solution for the process…

If you know exactly where its fail everytime, maybe you could try to add a try catch with a screenshot activity? So when it’s fail to use the selector, you will be able to see what the screen was looking like, as the problem seems to happen only with the Orchestrator? :slight_smile: That might be a first step to find out about what the problem is.

1 Like

thats a fantastic idea! we will do that right now, an tell you the result! :smiley:

seems like we are not able to do that right. the failure message is like “click … timeout reached”. so we installed a tryCatch with TimeoutException. but that does not work. the process throws the same failure, but does not execute the trcatch routine. Can you help?


Hello Mohab,

I face the same error . Did u find solution for yours?

hi RajaniG. Sadly we have still no solution for this, no. We reorganized the prozesses, so they do not run at the same time. but this is no solution for the future. so if you find a solution, i would really apreciate if you could let us know.
(btw: i could not fix the tryCatch-Screenshot-Idea either. This was a good idea, but we needed to go the “faster way” by reorganising the orchestrator-Triggers)

Hello, I have the same issue. I put take screenshot activities before the known error occured. I found out that what changes when the robot succeeds and doesn’t is that the chrome tab, even though is open, it’s icon is blinking orange, like it isn’t open really. I then tried to add some activate activity, but when the process is pending, the selector gets an error too, but the chrome window is fully opened and visible, its just looks like its not.

I think this can be related to some kind of configuration issues, because the robot doesn’t log off between the processes, I think it should, to be as clean as possible.

Did you find any solution?

Thanks in advance.

Hello,

I was able to solve the problem by introducing in the KillAllProcesses.xaml the activity to Get Processes and, with a for each, kill the processes I want, one by one (eg.: chrome, EXCEL).
Then I added 1 min of delay after the for each and also in the InitAllApplications.xaml before opening any programs. That gave me 2 min to make sure that all the processes running in the machine had time to close properly.

Hope it works for you too.

Regards,
Catarina