Password security control issue

uiautomation
security
studio

#1

Hi guys.

Currently we’ve stuck in a situation: we need to login to a bank website so password should be typed in. But the textbox where password typed in has security control, which prevent any activities to type in.
image

We’ve tried type into, send hotkey, copy, virtual keyboard and any other similar activities but all failed. Now we’re using remote desktop control to achieve this but it’s way too unstable and slow.

Any ideas or similar experience and solution? Thanks.


#2

Hi @Rynn,

First of all try to use Internet Explorer11, if its a web based app.
IE11 prevents any kind of COM component errors.

1.> If this is a web based application , then right click on that input field and click on inspect element.

And try to change the Input type attribute to “text”.

And try to type in. - This may help :slight_smile:

2.> Else,I see a keyboard icon aligned on the right , try to click on it and probably if it gives u a virtual keyboard, try to use click activity to click various keys.

Hope it helps


#3

Thanks for your reply.

It is web based page. Due to environment limit, we could only use IE11 and I opened the developer tool to take insight, it appears an encapsulation:

About that virtual keyboard icon, every other thing except the keyboard is prevented and it shows up on another layer, even click with absolute cursor the click would happen under that keyboard.

Before you could type into password, you need to install the bank’s security control first, then the ‘special textbox’ appears after restart browser.


#4

Hi @Rynn ,

This looks pretty challenging and I would like to give it a try.

Please could you share the link of this website and I will only try to enter few keystrokes in the password field.

If i am able to do it , I would share the solution with you.

I work for an IT Giant IBM, so i do understand the importance of not sharing the personal / client’s sensitive info.

But u can trust me and I will give it a try.
Regards,
Prashant Siingh


#5

https://ebank.sdb.com.cn/corporbank/logon_basic.jsp
Here is the link. This is a bank’s login website, so you could do anything you want to try to just type ins.
You need to click the blue font link in the red box to download and install the security control and restart the browser. Thanks.

IBM is impressive and attractive for me who is working in IT/consulting corp. too. Thanks for your patience and help.:smiley:


#6

Hi @Rynn,

I m sorry , cant access this portal - maybe coz my company firewall is blocking it.


#7

No problem.:smiley:


#8

Hi Rynn,
Have you solved the problem, if you have, could you please share the solution.

we are facing the same problem.

thanks