Passing argument error

I am using a folder path “C:\Praveen\B10\B10\classification report\20-Jun-2019” in arguments in uipath but the folder path gets truncated automatically while trying to save files in bot

Hi @prvnmr679,

Can you please share screenshot(s) of how you’re passing the path to the workflow from start till it gets to this window?

Hi, I also faced same issue, do not use normal activities, try with recording it will work fine.
Cheers

Hi @prvnmr679,

Potentially the process is going too fast and the bot is typing before the save popup has finished loading? Could try adding a delay or On Element Appears activity to test it out :slight_smile:

Hi @mcicca, Hope you were right about bot working Too fast, i tried to delay 4000 millisec, and the issue is not in passing arugments.

i tried to use the folder path directly in the activities field and still i am facing error and now directory “c” alone is missing in the path these are the images of path i have used in activities. Please your support


@goodoldme
sorry i was mistaken, Its not about passing arguments.

I have explained the scenario in response to mcicca’s comments

@prvnmr679

In the properties of Type Into Activity, set delay before to 3000 millisec and also check Click Before Typing and Empty Field options.

@lakshman



i did as you mentioned still the same error bro

@prvnmr679

Do one thing. Assign this path to one String variable and pass it to Type Into Activity. Try this way and check once.

And also you can use Set Text Activity also to do this.

Hi @prvnmr679

  1. Can you please confirm if SimulateType is Checked for the Type Into activity?
  2. Can you try using Path.Combine to build the filepath to see if that helps?
    Path.Combine("C:\Praveen\B10\B10\classification report\", Today.ToString("dd-MMM-yyyy"), customer, "_", item)

@goodoldme Thanks you so much. Now it is wroking fine

1 Like

:+1:t4: @prvnmr679 It would help others in future if you can please mark the solution.

Issue Fixed Answer:
SimulateType was unchecked before, I checked the simulate type of the Type into activity

That fixed the error. I would appreciate your help if you could explain me the actual issue happened here. I had no idea on simulate type

Thank you so much for notifying that @goodoldme

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.