Page doesn't load until connect to VM

Hi there,

My automation requires opening an Office 365 URL and logging in with the o365 portal. This works fine when I run it on the dev server I’m using. However, if I hit run on the robot then I disconnect from the server while the robot is running, the Chrome window never loads the page and is just white/blank page…
I notice that when I connect to the VM again to check on the robot the page in Chrome is stuck on a blank/white page and then suddenly everything loads and robot kicks in… if I leave it long enough on its own it just times out.

Is there something I can do to make sure the page loads correctly even in the background while disconnected?

Hello @Jon_G

Hope your robot is running in the VM. Also which activity are you using to open the url??

Using the Open Browser activity - Chrome, New Session, and output the browser element

Works fine when I’m on the server running it from UiPath Studio. When I disconnect from the server (I do this to test everything runs okay in the background), I notice the page only half loads to a white/blank page and it doesn’t load the rest of page until I connect to server again. It’s as if the Office 365 portal is waiting for an active connection before it continues.

I tried Refresh Browser but that doesn’t seem to do anything

I found the solution to my own problem. Hope this helps others. :slight_smile:

in Chrome go to chrome://flags and go to ‘Calculate window occlusion on Windows’ and Disable it from the dropdown box. Relaunch chrome, and it will work.

The issue was that with this setting enabled, sometimes Chrome is waiting for the window to be manually ‘focused’ before loading the full page contents. This was causing issues with UiPath for this URL I was trying to navigate as a background process. Hope this helps others and may apply to other URLs!

More info - Background tabs and pages not loading until focused on - Google Chrome Community

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.