Packages not getting deployed on Robots machine

orchestrator

#1

HI Team,

We have provisioned robot on Orchestrator. Created a simple process to log message. Uploaded the package on Orchestrator.

  1. When we add a process and select the enviroment. Package automatically gets copied/deployed on all Robots machine (assigned to that enviroment). But its not geting deployed

#2

Hi @Tanujasethi,

What do you mean by “it’s not getting deployed”? It’s not displayed in the Processes page?


#3

Hi,
Did you mean process is not created ?
If process is visible on the process tab and wants to run it on machine then you need to go to Job Tab and from there you need to run the the process .
If above steps done and still not running then please let us know the logs or if any error messages.

PS:Hope you have configured right machine name .


#4

it is displaying on the process page.
I have developed package on my system. I want to run this process on VM.
I have configured the VM Robot properly and robot status is coming as Available on Orchestrator.
Now after provisioning my robot -> Created Enviroment -> Assigned robot to it.
CReated Process (selected the package that i upaloaded) , enviroment. Process is visible on the process page.

  1. SO now whenever we create process with selected package and enviroemnet, then automatically that package should get copied to VM machine/Robot Machine?
  2. Now when i am running the process from job tab , its giving exception attachd the screenshot:

#5

Hi,

Give a try .:slight_smile:

Usually appears when you use High-Density Robots (server machine with multiple users) and you have the logintoconsole parameter set to true in the UiPath.settings file.


#6

We have one user on this server. DO you want me to set logintoconsole parameter set to true or false in the UiPath.settings ?file.


#7

set to True and try ,else we’ll find other way around.


#8

ALso where i can find his file? in which folder?


#9

logintoconsole parameter value is TRUE in settings file


#10

oh fine.
Please check and try to follow up the steps and let us know.


#11

Hi @Tanujasethi

When you deploy a process, the Robots in the given environment have access to all the activities they need to execute the automation project(more info about this here). You will see your process(and evironment) in the Robot tray after deployment.


#12

HI
I have added the UIPATH_SESSION_TIMEOUT Enviroment variable . But still i am getting the same error.


#13

@Andrei_Pop


#14

So you have a firewall/antivirus ? If you do, please turn them off and retry.

From the error it seems that the download cannot be done in 30 seconds (timeout).

On the robot machine please open robot tray and hover the mouse on the status icon.

Andrei


#15

I have turned off the firewall but still its not working