Packages not fetched from Orchestrator thru Studio Panel

How to fetched from Orchestrator the packages thru Studio Panel ?

Once the developer creates a process, the download packages from external sources. Then developer has to get approvals from appropriate security person to allow to uses these packages in the infrastructure. The developer or his/her manager uploads these packages to orchestrator library and then there is no issue for the end user (robot) to download them from orchestrator only once the process is published.

This is a secure approach, to avoid possible situation when “infected” or “malicious” package is downloaded by developer and widespread automatically thru whole company’s network automatically when published and used by end- user. As we have examples in general, not only in the organization, but same risk applies when downloading approved mobile apps to the smart-phone from official Apple or Google stores, right?

The developed process contains java packages and after importing to Studio 2021.4.4 client, it is presented as red.
When trying to manage it (either downgrade the version or repair) - the error occurs that package is not found in any source (Official, NuGet, Orchestrator location).
Necessary ports are opened in firewall (80, 443) to and from orchestrator. In addition, in Studio, when selecting manage packages; no packages are listed for selection from Orchestrator source at all.
When checking the folder in the orchestrator itself, there are plenty of packages but somehow they are not presented in studio.The deployment is done in three network subnets

  1. VM subnet where all robots, developer devices are located
  2. Orchestrator server
  3. SQL server with DB