Own .dll is not working

studio
assembly

#1

Hi Guys, I’ve just followed this example: https://www.uipath.com/kb-articles/how-to-execute-your-custom-code-in-a-workflow with this example. Everything was fine, I’ve installed the package, but I didn’t see any new action. Does it work for you? I’m just missing the last step of the tutorial, how should the action look like. The name of the method should be there? Any experiences, please? Thank you so much in advance! :slight_smile:


#2

Hello!

Probably have some issue regarding your Custom Activity. When correct created, the new activity is show up on Activities Panel.

Like this:

Regards,


#3

So Capgemini is the name of the .numpg package? Cryptography is the name of the dll and inside Cryptography are the methods? Or how does it work, please? :frowning: I will try to do screenshots or record video to show you, how does it/not work for me.


#4

The name of the .nupkg is “CapgeminiActivities.1.0.0.nupkg”. Inside it, on my project created with C#, I have a solution named Capgemini. And then I have methods which is each subActivity (Email, Http, Number, etc).

You have to organize your project (C# or VB. NET) created to Uipath be able to identify each one and create the Activities on Activities Panel :smiley:

Take a look into this. It may help you:

http://www.dotnetcurry.com/ShowArticle.aspx?ID=378

Regards,


#5

Sh*t, I did the same, but its not working for me :D. But thank you so much, I hope, that I will figure it out. UiPath is much more customizable than the other RPA tools, thats the reason, why I really like this tool :). But honestly, this dll looks a little bit uncomfortable in comparison with BP or Automate BPA, where you can just simply load your dll and its working properly :).


#6

It just a question of practice. When you get the first one correct, all the others will be much easier. You will not regret of using Uipath as a RPA Tool. I work with it about 2,5 years and for me is the best RPA Tool ever :wink:

Good Luck with this :smiley:

Regards,


#7

Regards…!!
Aksh


#8

The video looks be helpful, let me try to fix it today afternoon, I will let you know, how does it work for me. Anyway, thanks a lot for your help!

Best Regards,
Franta


#9

So guys, firstly, let me thank you again for your help, but its still not working :frowning: :(. Attached screenshots, maybe you will be able to see the issue. Thank you so much in advance!


#10

Guys, still doesn’t work for me :(. Any other suggestion, please? Thank you in advance.


#11

Try including GMailSend.dll in the package as well or add proper dependencies to the .nupkg.


#12

I will try it, thank you so much, Andrzej :).


#13

Hello. Once you finally manage to include it and show it within UIPath scope, it is pretty easy. Please show us the exact code as it is the best way to start to find out the causes.


#14

@fdolsky Add two reference to your code in Visual Studio.

  1. using System.Component model;
  2. using System.activities;

and when you create NuGet package in NuGet Package Explorer be sure to add your ‘.dll’ by Right-clicking the ‘lib’. like this:


Hope this will resolve your issue.
and if not work please let me know!!