Outlook: The specified folder does not exist issue

The way that I resolved it is:

  1. Tried running the same on a different machine with an enterprise version and it was working fine, so it was something wrong with my machine
  2. Tried reinstalling UIPath and activating it, issue persisted
  3. Tried creating a subfolder under Inbox and changing the folder to Inbox\New_folder, worked on my colleague’s machine, not mine.
  4. Tried assigning my email address in the email option, didn’t work
  5. Unchecking the only unread emails option, didn’t work
  6. Reducing the top emails number/ Increasing it… didn’t work
  7. Suddenly i realized it could be the countless community activities other than UiPath that i had installed, so I un-installed them all, didn’t work
  8. Then finally i went for uninstalling and re-installing Microsoft Office
  9. Also, along with this issue, i was facing issue with Excel Application Scope as well, so that confirmed something was definitely wrong with Microsoft Office

So, reinstalling Microsoft office did the trick for me. Thanks


Hi, I am facing the same issue.
Get Outlook Mail activity worked fine when using UiPath Studio version 2018.2.3

However, after upgrading to version 4.0, this activity worked abnormally and started to popping up this exception. I can only trying to solve this problem by restarting the outlook 2010 few times.
I do not think this is a decent way to solve this problem, since I have to check the robot frequently to keep my workflow working. I do hope someone can help me wording on this.

Many thanks,

Tryied all combinations. Nothing works.

Hi @carlossergio

Given that you respond to an old thread, please consider creating a new one or providing more information specific to your issue.

1 Like


Try to kill Outlook Process in Task Manager and run again. That solved issue for me.


help me please