Outlook: The specified folder does not exist issue

okay sure!

My UiPath Studio version is running on the 2018.1.1 and my Outlook is running on the 2016 MSO (16.0.4266.1001) 64-bit version.

Ps: Hope your not talking about outlook web app.

I am using the one that is in Microsoft Office Professional Plus 2016.

Will try on my end to add the package.

Thank you!

I have tried the 1.1.6241.16119 version for the mail package, it gives me the same error as well. :frowning_face:

ok i’m not using 2018 and it’s hard to say it’s a bug.
Let QA team have a look . @Gabriel_Tatu
Does send/move outlook mail activity works fine ?

can try something like this : mailfolder= "yourmailid\Inbox"

does not matter what Studio version you use if you have the same package version.
there are no known issues when getting emails from an outlook account, so i suspect something related to that environment.
when the wf starts, do you see the outlook process started? it won`t be visible but you can monitor task manager

Hey,

can try something like this : mailfolder= “yourmailid\Inbox”

I have tried this before too and it doesn’t work in my case :frowning:

hey,

Yes, i do see that the Outlook process starts and then stop when the error pops up.

what outlook version are you using? is it closed or opened?

Hi Gabriel,

Apologies for the late reply, my Outlook is running on the 2016 MSO (16.0.4266.1001) 64-bit version. I’ve tried running Outlook both closed and opened and unfortunately it doesn’t work!

What kind of account are you using? Gmail?

I am using Outlook!

Same problem here “The specified folder does not exist” Outlook 2007 and latest package. Have already tried all the possible solutions commented.

1 Like

Hope this will work for you. Looks some admin privileges issue

  1. Close the Outlook
  2. Open it using “Run as Administrator”
  3. Execute the program.

Let me know if it works for you. I was facing the same issue and it gave me the way to read outlook.

Hi,

I guess it´s too late for you now, but might happen to other people in the future: I also had the same issue with Outlook, I checked all the forum topics, and nothing worked for my case.

In the end we had to uninstall and reinstall Outlook again, and the issue was fixed! We tried a newer version just in case, but it could be that it was a configuration problem, more than a version one, as my colleagues were using the same version and they had no problems with this activity.

Ander

Just put the exact account in the Account property in Get outlook mail messages activiy.

image

The way that I resolved it is:

  1. Tried running the same on a different machine with an enterprise version and it was working fine, so it was something wrong with my machine
  2. Tried reinstalling UIPath and activating it, issue persisted
  3. Tried creating a subfolder under Inbox and changing the folder to Inbox\New_folder, worked on my colleague’s machine, not mine.
  4. Tried assigning my email address in the email option, didn’t work
  5. Unchecking the only unread emails option, didn’t work
  6. Reducing the top emails number/ Increasing it… didn’t work
  7. Suddenly i realized it could be the countless community activities other than UiPath that i had installed, so I un-installed them all, didn’t work
  8. Then finally i went for uninstalling and re-installing Microsoft Office
  9. Also, along with this issue, i was facing issue with Excel Application Scope as well, so that confirmed something was definitely wrong with Microsoft Office

So, reinstalling Microsoft office did the trick for me. Thanks

2 Likes

Hi, I am facing the same issue.
Get Outlook Mail activity worked fine when using UiPath Studio version 2018.2.3
image

However, after upgrading to version 4.0, this activity worked abnormally and started to popping up this exception. I can only trying to solve this problem by restarting the outlook 2010 few times.
I do not think this is a decent way to solve this problem, since I have to check the robot frequently to keep my workflow working. I do hope someone can help me wording on this.

Many thanks,
Daisy

Tryied all combinations. Nothing works.

Hi @carlossergio

Given that you respond to an old thread, please consider creating a new one or providing more information specific to your issue.

1 Like

Hey,

Try to kill Outlook Process in Task Manager and run again. That solved issue for me.

https://forum.uipath.com/t/unsent-files-are-only-saved-in-drafts/227205?u=arifudinmyf

help me please