Outlook Save Attachment Issue

Hi all,

I need a bot that will go through a folder in outlook, grab an attachment, rename and send to someone else. For some reason it will not send the attachment. I tried saving it initially somewhere locally, but when i run the bot and check the folder, it is empty. It does not throw an exception and i cannot figure out why it won’t save the attachment. i am using the “save attachments” activity

Any one have any similar issues?
Any thoughts?

Hi @alex1

Save attachment activity maybe the filename you are passing or character kind of thing got missing


Hi Thanks for your response, although I am not sure I am following. There is a PDF attachment in each email. I am really just trying to save that PDF to a local location on my pc. I also use the Read PDF Text activity, and that is able to read the PDF and get the info i need without any issue And if it had to do with what you suggested, shouldn’t it throw an exception? It runs fine and does everything i need it to except saving the attachment

Hi Alex,

If you are on a domain joined machine it may be GPO as I am seeing an issue where a group policy is blocking this and results in no errors but no saved attachments.
I am still trying to track down the exact policy however I have narrowed it down to a user policy and not a machine one.

This Post references some reg keys that block other elements of outlook but from what I can tell the attachments aren’t blocked here.
This post confirms the issue is GPO related but dosn’t list the policy.

Did you manage to resolve your issue? and was it GPO?