갑자기 Orchestrator에서 트리거에 특정로봇이 보이지 않네요

오케스트레이터에서 작업 예약 해 놓은게 있는데
이게 어제부터 갑자기 시작 안되서 봤더니
트리거에서 특정로봇에 지정한 로봇이 보이지 않습니다.

트리거를 새로 만든다음에 특정로봇을 선택해도 검색이 되지 않습니다…

무엇을 봐야 할까요?

1 Like

뭔가 버그인듯 하네요…저도 오늘부터 갑자기 같은 현상이예요…

저도 그래요. 아이콘도 하나 생기셨죠? 프로세스에. 거기 HOVER하면 REQUIRES USER INTERACTION이라고 나오고… 제 생각에는 ㅠㅠ UPDATE가 된거 같은데 그 영향으로 ROBOT을 인식 못하는거 같아요. ㅠㅠ FORUM에 가서 물어보니 다른 나라 애들도 같은 현상이 있는 듯 하더라고요.

오늘 안되서 들어갔더니 못보던 아이콘도 생기고
뭔가 업데이트 된거 같은데…
저만 그런게 아니였나보네요…

Robot -> Environments 메뉴로 진입하셔서 Robot이 정상적으로 등록이 되어있는지 확인해보세요.

혹 안되어있다면 해주시고요. Robot에 Robot이 안보이산다면 다시 재 등록 해주시면 됩니다.

로봇 등록 되어있고 재등록 해도 동일 합니다.

현 오케스트레이터 버전은 어떻게 되시나요?

라이세느는 확인해 보셨나요??

저도 마찬가지 현상입니다…스케쥴내에 로봇이 진행되지 않네요…

There are some updates on Orchestrator v20.3
You have to change type of Robot to Unattended

Orchestrator v20.3에 일부 업데이트가 있습니다
로봇 유형을 Unattended으로 변경해야합니다

2 Likes

이거 공지는 왔네요.
해결하셨어요? 따라하면서 하긴 했는데 ㅠ 전 좀 많이 헷갈렸어요.
아직 못하신 분들 계실까봐 말씀 드려요.
공지에서 나온 방식은

  1. enable modern folders in orchestrator setting
  2. edit the user and attach an unattended robot to it
  3. create a machine template and attach both the user and the machine to it
  4. create modern folder and attach both user and machine to it
  5. deploy the process in the modern folder

이렇게 인데요, 간단히 말씀 드리면

  1. Orchestrator에서 왼쪽에 MANAGEMENT 하위에 있는 USER로 가세요
  2. 본인 이름이 admin으로 되어 있잖아요. 우측에 쩜셋을 눌러 Edit로 가세요
  3. 거기보면 3번에 Unattended robot이 있어요. toggle 버튼을 눌러 enable하게 하고
    반드시 robot이 있는 desktop의 비번을 넣으세요.
    4.이제 다시 Orchestrator에서 왼쪽의 MACHINE로 가신다음에 MACHINE TEMPLATE으로
    하나 만드세요.
  4. Template name 정하구 아래에 License-Unattended Runtimes에 1을 넣으세요.
    음…이게 맞는지 모르지만 일단 전 1을 넣었어요.
  5. 이제 UiPath Desktop으로 가세요. 이제 이름이 UiPath Assist로 변경 되었어요.
  6. Orchestrator setting에서 방금 만든 Machine Template의 Machine key값을 넣고 링크하세요
  7. 다시 Orchestrator로 오셔서 역시 좌측의 FOLDER로 가세요.
  8. 새로 NEW FOLDER를 MODERN TYPE을 만드세요.
  9. 만들면 우측에 USER와 MACHINE을 넣을 수 있어요.
  10. USER는 본인 ADMIN넣으시고 MACHINE에는 MACHINE TEMPLATE 만든거 넣어요.
  11. 이제 우측 상단의 이름 왼쪽에 보면 DEFALUT와 MODERN을 선택할 수 있어요. MODERN을 선택하세요.
  12. PROCESS로 가셔서 평소 처럼 하시면 됩니다.

USER 메뉴의 admin에 쩜셋에 있는 Edit가 비활성화 되어있는데 어떻게 푸나요?

:loudspeaker: An important note

Starting with this version, you will no longer be able to start jobs or create triggers from Orchestrator on a Robot of type Studio or StudioX. In order to start processes from Orchestrator , you should use an Unattended Robot. Each Community account has 1 Unattended Robot included.

오케스트레이터 우측상단에 있는 계정 눌러서 설정 들어가면
설정에 일반에 있는 최신 폴더(Modern Folders) 체크 하면 편집 됩니다

위 내용으로 등록을 했는데 Job에서 프로세스 실행 시 STATE가 Pending 상태에서 진행이 되질 않습니다. 확인방법이 있을까요?